• 0

    posted a message on Thebombzen's Mods
    Quote from horstroad»

    There is a recommended version of forge now. Are you going to update, or are your mods dead? I really liked them ._.


    Honestly at this point I can say "Maybe?" I'm just so busy IRL right now.

    Posted in: Minecraft Mods
  • 1

    posted a message on Thebombzen's Mods
    Quote from IXTRD»

    Hey thebombzen, is this pack being worked on for 1.13 or have you stopped updating? Not trying to rush anyone, just wondering haha, because its an awesome mod I've used over the years real good work.


    And if development has stopped, does anyone know where I can find an updated mod like this for 1.13, it's really a great feature.


    Thanks.


    There's no Recommended version of Forge yet. I'm going to wait until Forge becomes a little bit more stable.


    In other news, I fixed the bug about the config screen in older versions. Should work now.

    Posted in: Minecraft Mods
  • 0

    posted a message on Thebombzen's Mods
    Quote from LionLoren»

    Sir, I don't know if you could help me, but i'm having some difficulties making autoswitch understand that my tinkers construct shovel is the perfect tool for sand digging, rather than my shuriken.
    What can I do to fix this?


    Send me a debug report. See the FAQ for instructions.

    Quote from hairanndo»

    problem:

    The optimum tool is not selected.

    use ver:

    autoswitch 5.6.2 ThebombzenAPI 2.9.2 minecraft 1.10.2

    Detail:

    Shovels are selected for "Snow Block" and "Grass Block", but bare hands are selected for ordinary "Soil Block".


    Send me a debug report. See the FAQ for instructions.
    Quote from TheSim14»

    Hey,


    how can i add the conduits/machines from enderio and cable from applied energetics for pickaxe?



    Would be nice if u can help me.



    Greetz


    That's in the AutoSwitch overrides file. You can get to it from the settings window. Instructions are on the inside.

    Posted in: Minecraft Mods
  • 0

    posted a message on Thebombzen's Mods
    Quote from Khiel»

    problem: enchantview can use only admin

    decision: add a - thebombzen.mods.enchantview.CommandEnchantViewExists in permissions.yml


    EnchantView hasn't even been updated yet. I still need to get around to that.
    Posted in: Minecraft Mods
  • 1

    posted a message on Thebombzen's Mods

    AutoSwitch (and the API) now work with Minecraft 1.12.2. I still haven't updated EV yet because I'm placing a higher priority on maintaining and squashing bugs in AS. Plus I'm still busy IRL and things. EV will come Soon™.

    Posted in: Minecraft Mods
  • 1

    posted a message on Thebombzen's Mods

    I've published a quick patch - AutoSwitch 5.6.1 and ThebombzenAPI 2.9.1. Update reminders now work correctly if you have it set to current minecraft version only - that is, now it not only will work but it'll point to the latest released as long as it's compatible with your version. I've also fixed the update reminder messages so they now will say "Minecraft 1.9.4 to 1.12.1" in case anyone is worried about compatibility.

    Posted in: Minecraft Mods
  • 1

    posted a message on Thebombzen's Mods

    I've published the two updates described above! EnchantView this weekend, hopefully.

    Posted in: Minecraft Mods
  • 3

    posted a message on Thebombzen's Mods

    Updates!


    1. I've figured out a fix for both the toggle key bug and the audio spam bug. They'll be included in the next published patches.
    2. I've figured out how to port AutoSwitch (and ThebombzenAPI) to Minecraft 1.12.1. The next versions I publish will support Minecraft 1.9.4 through 1.12.1.
    3. I'm going to update the installers to install itself into 1.9.4, 1.10.2, 1.11.2, and 1.12.1. If you do not want this behavior, you can always install manually. This won't take very long or be very difficult.
    4. After I publish these, I'll get working on upgrading EnchantView to 1.9.4 through 1.12.1.
    Posted in: Minecraft Mods
  • 1

    posted a message on Thebombzen's Mods

    Update about known bugs:


    You can submit bugs and track them on my bug tracker on Github. (AutoSwitch, EnchantView, ThebombzenAPI). These are currently open bugs:


    Holding down a togglekey repeatedly causes it to toggle on and off #4

    Digging with AutoSwitch enabled plays audio on repeat #5

    Update EnchantView for 1.11.2 #2

    Posted in: Minecraft Mods
  • 0

    posted a message on Thebombzen's Mods
    Quote from Matakor»

    Hey, I'm not certain what's going on with the latest version (I'm on mc1.10.2), but with autoswitch enabled, I'm suddenly getting an audio glitch where a file seems to repeat in extreme speed (very loud 'BDBDBDBD' kind of sound, hard to articulate). It only happens when I'm attempting to mine or break something where autoswitch would activate. disabling it with f10 removes the problem, so pretty certain it's autoswitch causing it.



    Quote from VinhDucanh»

    If you find the problem with the audio glitch please post it. I have the exact same problem.


    I just reproduced this bug. I'll look into what's causing it and publish an update.
    Posted in: Minecraft Mods
  • 0

    posted a message on Thebombzen's Mods
    Quote from Xolt»

    By the way, on the latest autoswitch, for some reason when I hold down the F10 key, it constantly toggles on and off at a very fast pace. Once I finally toggled if off, I couldn't get it to toggle back on because when you press it, it always toggles twice or more.



    I'm aware of this bug. I'm going out of town this weekend for the Eclipse, but I'll try to publish an update in the next few days after I get back.

    Quote from Xolt»

    Edit: It seemed to be toggled off, but for some reason when I try to mine a block with a tool, it switches to an empty hand instead, and when I stop, it switches back to the tool.



    It should do nothing if it's toggled off. Can you send a debug report? Enable Debug Logging, trigger the bug, and then use a paste site like http://pastebin.com/ or http://gist.github.com/ to send me

    .minecraft/mods/AutoSwitch/DEBUG.txt
    Posted in: Minecraft Mods
  • 0

    posted a message on Thebombzen's Mods
    Quote from Moepius»

    thanks for keeping us up to date :)


    You're welcome :)
    It's nice to see that people are still interested so it's the least I can do
    Quote from Xolt»

    Is an update planned for 1.10.2? It is a commonly used version.


    I just published AutoSwitch v5.5.1, which works with 1.9.4 through 1.11.2. You will need to install it manually though, seeing as the automatic installer will deposit it inside mods/1.11.2. The existing API that I just published should already work with it.

    Let me know if you find any sort of incompatibility that you cannot reproduce in 1.11.2 (or rather, if you find any sort of incompatibility at all) and I'll try to fix it.
    Posted in: Minecraft Mods
  • 0

    posted a message on Thebombzen's Mods
    Quote from Xolt»

    Is an update planned for 1.10.2? It is a commonly used version.


    Yes. Forge makes it so I don't have to compile separate versions for the mods, although if they reference incompatible changes in Minecraft, I do have to deal with that.

    The API works out of the box in 1.10.2 and 1.9.4, and I figured out how to get AutoSwitch to work in both. I'm going to publish AutoSwitch version 5.5.1 shortly, which should work in anything from 1.9.4 to 1.11.2.
    Posted in: Minecraft Mods
  • 1

    posted a message on Thebombzen's Mods

    AutoSwitch and ThebombzenAPI are both on 1.11.2. Download links are up already. If anything doesn't work as expected, please feel free to let me know here so I can release a hotfix.

    Posted in: Minecraft Mods
  • 3

    posted a message on Thebombzen's Mods

    Status Update:


    I've updated ThebombzenAPI for 1.11.2. AutoSwitch coming Soon (TM), followed by EnchantView. I won't update the API download links until I update AS.


    EV spigot plugin will have to wait. That will take more time and energy than I have right now.


    Why not 1.12? Baby steps please. I have no idea if that'll be trivial or difficult. Especially considering that most forge servers are on 1.11 anyway.


    I have no idea about the binary compatibility between 1.11 and previous versions. That is, I have absolutely no idea if 1.11 mods will run on 1.10. I'm guessing they will not. If this is not normal, they won't. If this is normal, they might? This used to be very clearly "no" but I don't know what sort of innovations Forge has figured out to make it work.


    But yea, it's coming. When I said I'd update it, I did mean it. Even if it's years late.

    Quote from Moepius»

    I don't see a chance that this Mod will be up to date ever again. 1.11

    is coming up .. at some point when a mod has missed some

    updates the devs usually stop updating 'cause they cant catch up.

    But I hope it wont happen ... I love this mod




    Quote from BluishCraft99»

    Will this get updated anytime soon?





    So I'm just gonna assume these mods as been abandoned considering they haven't been updated in months quite sad




    Be nice to see this plugin get some love. I miss having it.


    Well then I have good news ;)
    Posted in: Minecraft Mods
  • To post a comment, please or register a new account.