• 0

    posted a message on Lag and DC for 30 seconds on joining server, tp, and spawn.
    Thanks for the reply, here's some of that info:

    PC

    Java version 1.8.0_20

    World ported over from 1.7

    Custom Server

    Unfortunately the server logs don't give me any errors that tell me anything helpful. Are there specific connection logs? Is there a verbose logging option?

    Here's a segment of the servers normal logs from one of the connections where I experienced about 15 seconds of login lag, but no disconnection.

    lt;br>[10:18:44] [User Authenticator #3/INFO]: UUID of player Wivru is eaeea84d-8796-4515-b36e-e7e0096c5506
    <br>[10:18:44] [Server thread/INFO]: Wivru[/71.81.217.125:51057] logged in with entity id 206277 at (103466.16069616337, 66.0, 127417.57114986303)
    <br>[10:18:44] [Server thread/INFO]: Wivru joined the game
    <br>[10:18:51] [Server thread/INFO]: <Wivru> test
    <br>[10:18:54] [Server thread/WARN]: Wivru moved wrongly!
    <br>[10:19:01] [Server thread/WARN]: Wivru moved wrongly!

    Here's an example where logging in resulted in an immediate DC. Specifically, the player Lecloche is trying to get in over and over again and keeps getting booted after 30 seconds of lag. Note that several times he logs in again before the server even notices he's logged out:

    lt;br>[21:56:46] [User Authenticator #16/INFO]: UUID of player Lecloche is 68568efd-767e-4f9c-a40e-40347eae98b7
    <br>[21:56:46] [Server thread/INFO]: Lecloche[/216.172.83.194:49784] logged in with entity id 209855 at (103475.5, 67.0, 127394.5)
    <br>[21:56:46] [Server thread/INFO]: Lecloche joined the game
    <br>[21:57:03] [Server thread/INFO]: <Lecloche> test
    <br>[21:57:07] [Server thread/WARN]: Lecloche moved wrongly!
    <br>[21:57:14] [Server thread/INFO]: [Server] you okay?
    <br>[21:57:19] [Server thread/INFO]: <Lecloche> login lag
    <br>[21:57:21] [Server thread/INFO]: <Lecloche> yes
    <br>[21:57:51] [Server thread/INFO]: <Lecloche> test
    <br>[21:58:03] [Server thread/INFO]: <Lecloche> test
    <br>[21:58:45] [User Authenticator #18/INFO]: UUID of player Lecloche is 68568efd-767e-4f9c-a40e-40347eae98b7
    <br>[21:58:45] [Server thread/INFO]: Lecloche[/216.172.83.194:49873] logged in with entity id 212028 at (103441.0, 67.00999999046324, 127362.0)
    <br>[21:58:45] [Server thread/INFO]: Lecloche joined the game
    <br>[21:59:07] [User Authenticator #19/INFO]: UUID of player Lecloche is 68568efd-767e-4f9c-a40e-40347eae98b7
    <br>[21:59:07] [Server thread/INFO]: Lecloche[/216.172.83.194:49884] logged in with entity id 212689 at (103440.41212455109, 67.0, 127362.25597601727)
    <br>[21:59:07] [Server thread/INFO]: Lecloche joined the game
    <br>[21:59:30] [User Authenticator #20/INFO]: UUID of player Lecloche is 68568efd-767e-4f9c-a40e-40347eae98b7
    <br>[21:59:30] [Server thread/INFO]: Lecloche[/216.172.83.194:49903] logged in with entity id 213105 at (103440.41212455109, 67.0, 127362.25597601727)
    <br>[21:59:30] [Server thread/INFO]: Lecloche joined the game
    <br>[21:59:35] [Server thread/INFO]: Lecloche lost connection: TextComponent{text='Disconnected', siblings=[], style=Style{hasParent=false, color=null, bold=null, italic=null, underlined=null, obfuscated=null, clickEvent=null, hoverEvent=null, insertion=null}}
    <br>[21:59:35] [Server thread/INFO]: Lecloche left the game
    <br>[21:59:54] [User Authenticator #21/INFO]: UUID of player Lecloche is 68568efd-767e-4f9c-a40e-40347eae98b7
    <br>[21:59:54] [Server thread/INFO]: Lecloche[/216.172.83.194:49915] logged in with entity id 213352 at (103440.41212455109, 67.0, 127362.25597601727)
    <br>[21:59:54] [Server thread/INFO]: Lecloche joined the game
    <br>[21:59:58] [Server thread/INFO]: Lecloche lost connection: TextComponent{text='Disconnected', siblings=[], style=Style{hasParent=false, color=null, bold=null, italic=null, underlined=null, obfuscated=null, clickEvent=null, hoverEvent=null, insertion=null}}
    <br>[21:59:58] [Server thread/INFO]: Lecloche left the game
    <br>[22:00:18] [Server thread/INFO]: Lecloche lost connection: TextComponent{text='Disconnected', siblings=[], style=Style{hasParent=false, color=null, bold=null, italic=null, underlined=null, obfuscated=null, clickEvent=null, hoverEvent=null, insertion=null}}
    <br>[22:00:18] [Server thread/INFO]: Lecloche left the game
    <br>[22:00:25] [User Authenticator #22/INFO]: UUID of player Lecloche is 68568efd-767e-4f9c-a40e-40347eae98b7
    <br>[22:00:25] [Server thread/INFO]: Lecloche[/216.172.83.194:49931] logged in with entity id 213785 at (103440.41212455109, 67.0, 127362.25597601727)
    <br>[22:00:25] [Server thread/INFO]: Lecloche joined the game
    <br>[22:00:31] [Server thread/INFO]: Lecloche lost connection: TextComponent{text='Disconnected', siblings=[], style=Style{hasParent=false, color=null, bold=null, italic=null, underlined=null, obfuscated=null, clickEvent=null, hoverEvent=null, insertion=null}}
    <br>[22:00:31] [Server thread/INFO]: Lecloche left the game
    <br>[22:01:05] [User Authenticator #23/INFO]: UUID of player Lecloche is 68568efd-767e-4f9c-a40e-40347eae98b7
    <br>[22:01:05] [Server thread/INFO]: Lecloche[/216.172.83.194:49952] logged in with entity id 214568 at (103440.41212455109, 67.0, 127362.25597601727)
    <br>[22:01:05] [Server thread/INFO]: Lecloche joined the game
    <br>[22:01:29] [Server thread/INFO]: Lecloche lost connection: TextComponent{text='Disconnected', siblings=[], style=Style{hasParent=false, color=null, bold=null, italic=null, underlined=null, obfuscated=null, clickEvent=null, hoverEvent=null, insertion=null}}
    <br>[22:01:29] [Server thread/INFO]: Lecloche left the game
    <br>[22:01:45] [User Authenticator #24/INFO]: UUID of player Lecloche is 68568efd-767e-4f9c-a40e-40347eae98b7
    <br>[22:01:45] [Server thread/INFO]: Lecloche[/216.172.83.194:49976] logged in with entity id 215970 at (103440.17943854218, 67.0, 127360.89650682003)
    <br>[22:01:45] [Server thread/INFO]: Lecloche joined the game
    <br>[22:02:33] [User Authenticator #26/INFO]: UUID of player Lecloche is 68568efd-767e-4f9c-a40e-40347eae98b7
    <br>[22:02:33] [Server thread/INFO]: Lecloche[/216.172.83.194:50015] logged in with entity id 217191 at (103440.17943854218, 67.0, 127360.89650682003)
    <br>[22:02:33] [Server thread/INFO]: Lecloche joined the game
    Posted in: Server Support and Administration
  • 0

    posted a message on Lag and DC for 30 seconds on joining server, tp, and spawn.
    (Moving this from the client forum to here)

    After upgrading to 1.8, me and my friend are experiencing about 30 seconds of very serious lag (can't type, move, interact, etc) whenever we join our server, teleport, or respawn. Oftentimes this results in a disconnection, so we have to retry to join multiple times (often resulting in lots of copies of us dotting our base). The lag only happens for the person actually joining - not the other player already on the server.

    I don't think ram (i.e. the stress of loading chunks on the computer's ram) is an issue, since that's something that has been working in previous versions (and the other player doesn't get laggy when someone joins - just the one joining). It seems to be a connectivity thing.

    Beyond that, I'm stumped. It looked a lot like this old thread:

    http://www.minecraftforum.net/forums/support/unmodified-minecraft-client/tutorials-and-faqs/1871648-fixing-lag-and-freezing-when-joining-a-mp-server

    But my attempts to reproduce that fix have failed, and I can't be certain that's the real cause anyway.

    Are other people experiencing this? Does anyone have a fix? Is there a log or something I can provide that could help solve this?
    Posted in: Server Support and Administration
  • 0

    posted a message on Lag and DC for 30 seconds on joining server, tp, and spawn.
    After upgrading to 1.8, me and my friend are experiencing about 30 seconds of very serious lag (can't type, move, interact, etc) whenever we join our server, teleport, or respawn. Oftentimes this results in a disconnection, so we have to retry to join multiple times (often resulting in lots of copies of us dotting our base). The lag only happens for the person actually joining - not the other player already on the server.

    I don't think ram (i.e. the stress of loading chunks on the computer's ram) is an issue, since that's something that has been working in previous versions (and the other player doesn't get laggy when someone joins - just the one joining). It seems to be a connectivity thing.

    Beyond that, I'm stumped. It looked a lot like this old thread:

    http://www.minecraftforum.net/forums/support/unmodified-minecraft-client/tutorials-and-faqs/1871648-fixing-lag-and-freezing-when-joining-a-mp-server

    But my attempts to reproduce that fix have failed, and I can't be certain that's the real cause anyway.

    Are other people experiencing this? Does anyone have a fix? Is there a log or something I can provide that could help solve this?

    Edit: Realized I'm on the client forum and moving this to the server, since that seems more likely:
    http://www.minecraftforum.net/forums/support/server-support/2222241-lag-and-dc-for-30-seconds-on-joining-server-tp-and
    Posted in: Java Edition Support
  • 0

    posted a message on Fixing Lag and Freezing when Joining a MP Server
    Quote from stevensa06»
    Alright, forgive the necro, but now that 1.8 is out, this seems to be rearing its ugly head for my server.

    Update: After digging opening the game in WinRar, I saw the naming scheme that MC uses, and found a name that wasn't taken in MC: bzv.class. I renamed "ServerAddress" to "bzv" in the ServerAddress.java file, compiled it, made a new profile and version in MC based on 1.8, deleted META-INF from the jar and added my class (in that order, and later tried the reverse), and confirmed that the new updated JAR and profile I was using wasn't getting automatically replaced on boot up, but I'm still experiencing the problem.

    A few questions:
    1) Do I also rename the "getServerAddress" function to "getbzv" or whatever, or just the class name itself?
    2) Is there any reason "bzv" wouldn't work?
    3) Why doesn't it work if we rename it "pqqqqqsServerFix.class" so we don't have to keep updating? Is there a reason we are sticking to minecraft's aaa, aab, aba, etc. name scheme?
    4) Why would we ever have to overwrite a file when dropping this in if the class name is available? Am I doing something wrong by looking at unused .class names in the jar file instead of doing the Class#ForName (which I don't quite know how to do)?
    Posted in: Java Edition Support
  • 0

    posted a message on Fixing Lag and Freezing when Joining a MP Server
    Alright, forgive the necro, but now that 1.8 is out, this seems to be rearing its ugly head for my server.

    I'm willing and able to implement this fix myself, but I don't understand one step:

    I'm supposed to download this ServerAddress source and then find and replace every instance of "ServerAddress" with something else, and recompile... right? But what do I replace it with? The OP has a different name for every version of MC (e.g. "bdl" and "bdi") and IcyIcicle seemed to figure it out (naming his "bwc"). Is there some pattern to these names that are getting chosen? Are we just picking names that aren't in use by minecraft yet? If so, why not go with pqqqqqsServerAddressFix.java, and not have a new file for every minecraft version?
    Posted in: Java Edition Support
  • 0

    posted a message on One Person Makes my CPU Freak Out
    My friend and I have been playing on a server I made, everything worked fine until recently.

    1) When he logs and enters the chunk that our base is in, now he gets horrendous (~30 second delay) lag for a few minutes and then disconnects.
    2) While he is ON and in that chunk, my server's CPU goes berserk. It normally hovers around 15% while I am playing, but it tops 90% whenever he logs on, even alone.
    3) The server logs TONS of "Can't keep up! Did the system time change, or is the server overloaded?"
    4) After he has been on and in the chunk for a while, the entire server, and all other players, start lagging.

    Problem 1 is happening on 1.6.4, and Problems 1-4 are all happening on 1.7.2.

    Edit: more info:
    -Logging on to both his and my accounts on my machines does NOT cause the problems.
    -Him logging into the server from his computer on my account DOES cause the problems.
    -Him logging on to the server from a different computer on a different network STILL causes the problems.
    -It ONLY happens when he is in this chunk - elsewhere in the world we are fine.

    Clearly something is corrupted - but I don't know how that works. How can I find out what it is? How can I fix it? The chunk is our base, so I would love not to have to delete the whole chunk.

    Any ideas?
    Posted in: Server Support and Administration
  • To post a comment, please or register a new account.