• 0

    posted a message on "OpenGL Error 1280" and "OpenGL Error 1281" spamming in chat

    I'm getting a similar Issue with Optifine U_E3 in minecraft 1.12.2... Perhaps it is the recent builds of optifine causing the bug?


    Online I was searching around and everyone says its a graphics driver issue, so I'd also try to fix that if you haven't already.

    Posted in: Java Edition Support
  • 0

    posted a message on OpenGL error 1283 - Stack Overflow

    UGH.


    I've just tested every mod in my list and it appears it is not a direct incompatability. Strangely, when I let each mod use its default configs it worked fine but I got the error once I configured each mod to my liking...


    Now I'm going to go through them all again and this time I'm going to see which mod configuration (and then after that, which specific setting) is causing the issue.

    Posted in: Mods Discussion
  • 0

    posted a message on OpenGL error 1283 - Stack Overflow

    Thanks for the reply, majesty! I Updated my graphics card driver (I've got an Nvidia Card) to v353.30 and reduced minecraft's ram allocation from 8G to 4G. My system had 16G of ram to spare, so I wasn't in danger of running out of memory but I didn't know that it stops being helpful after 4gb.


    Here's my system specs, in case they're relevant as well. I honestly doubt not having enough horsepower in my rig is the issue, but hey, I can't asume:


    Intel core i7-6700k 4GHz

    16.0Gb Ram

    nVidia Geforce GTX980Ti GPU


    Whelp, the issue is back, in spite of these changes. I'm not entirely sure what is going on here... Is there a incompatability? Do I simply just have too many mods on all at once?

    Posted in: Mods Discussion
  • 1

    posted a message on OpenGL error 1283 - Stack Overflow

    Hello,


    I am currently working on a mod pack, and I have been running into a extremely annoying bug. I've been trying to troubleshoot it, thinking that it might be being caused by an incompatibility between certain mods, but I can't seem to pin down what is causing it. It refuses to behave predictably as I add and subtract mods, and frankly doesn't even affect my game play that much, but I want to squash this bug now before it grows into something bad later.


    I am getting the console flooded with "OpenGL Error 1283: Stack Overflow" messages. We're talking, like, hundreds of them in an instant. I don't lose FPS, I'm not even getting a ton of TPS lag (at least, not any more than vanilla MC 1.12.2 has anyway). But, what I am getting when this happens is this:



    I am currently running minecraft 1.12.2 with forge version 12.23.5.2807. If it's relevant, here are the JVM arguments I'm using as well:


    -mx8G -XX:InitiatingHeapOccupancyPercent=10 -XX:AllocatePrefetchStyle=1 -XX:+UseSuperWord -XX:+OptimizeFill -XX:LoopUnrollMin=4 -XX:LoopMaxUnroll=16 -XX:+UseLoopPredicate -XX:+RangeCheckElimination -XX:+CMSCleanOnEnter -XX:+EliminateLocks -XX:+DoEscapeAnalysis -XX:+TieredCompilation -XX:+UseCodeCacheFlushing -XX:+UseFastJNIAccessors -XX:+CMSScavengeBeforeRemark -XX:+ExplicitGCInvokesConcurrentAndUnloadsClasses -XX:+ScavengeBeforeFullGC -XX:+AlwaysPreTouch -XX:+UseFastAccessorMethods -XX:+UnlockExperimentalVMOptions -XX:G1HeapWastePercent=10 -XX:G1MaxNewSizePercent=10 -XX:G1HeapRegionSize=32M -XX:G1NewSizePercent=10 -XX:MaxGCPauseMillis=250 -XX:+OptimizeStringConcat -XX:+UseParNewGC -XX:+UseNUMA -XX:+UseCompressedOops -XX:+UseConcMarkSweepGC -XX:+CMSClassUnloadingEnabled -XX:SurvivorRatio=2 -XX:+DisableExplicitGC


    Here's my full list of mods at the moment:

    Advanced Grapple Hooks
    Antique Atlas
    Artisan’s Worktables
    Athenaeum
    Atlas Extras
    AutoregLib
    Baby Animals Model Swapper
    Base Metals
    BetterFPS
    Bountiful
    Bullseye

    Crafttweaker2
    Disenchanter
    Familiar Fauna
    FoamFix
    ForgeEnderTech
    Forgelin
    Geographicraft
    Hardcore Darkness
    Ice and Fire
    LLibrary

    Lilliputian
    Muon

    Multimob
    Optifine
    MMD Orespawn

    Primitive Mobs
    Quark
    QuarkOddities
    Roguelike Dungeons
    Rustic
    SaltyMod
    Signposts
    SoundFilters
    Spartan Weaponry
    Spartan Weaponry - Base Metals Compatibility
    TextureFix
    Tough As Nails
    VanillaFix
    Villager Trade Tables
    Waystones


    What do you guys think is causing this?

    Posted in: Mods Discussion
  • To post a comment, please .