• 0

    posted a message on Java (tm) platform binary se

    Two recommendations:


    1. Update Java. Try downloading the JDK (Java Development Kit), not the JRE (Java Runtime Environment). Sometimes this works better.

    2. Update your graphics drivers if you haven't already.

    Posted in: Java Edition Support
  • 2

    posted a message on NEED HELP!

    Worlds aren't supposed to be backwards compatible. Don't try to open a world from a newer version in an older one.

    Posted in: Java Edition Support
  • 2

    posted a message on [1.14] Chocapic13's Shaders
    Quote from _HexaTech_»

    hi chocapic13. im a big fan of ur v5 of the shaders because it has the feature that lights up an area when you hold a torch/glowstone. maybe bring it up again on an updated v6 or a newer v7? also im using lite becuase my pc is a potato thx! :D <3


    That's an Optifine feature. Turn it on/off in the video settings.
    Posted in: Minecraft Mods
  • 0

    posted a message on [1.14] Chocapic13's Shaders
    Quote from 2metragluposti»
    Because I'm not seeing a specific bottleneck?

    (snip)



    The usual answer to problems like these is to make sure your graphics card drivers are up-to-date, but assuming that isn't an issue, you might see a benefit from turning of setting your framerate to unlimited, turning off v-sync (I know, I know, just hear me out) and playing with your settings. Turn on/off VBOs, fast math, stuff like that. Your GPU is a bit older so there might be something there that's not playing well with your hardware.

    How much is your framerate varying by? Minecraft isn't exactly known for its rock-solid steady framerates, even where the hardware should be more than powerful enough to keep things steady. You could also try a different shaderpack (not based on Chocapic13's shaders, SEUS is one good option) and see if you notice the same issues.

    Posted in: Minecraft Mods
  • 0

    posted a message on Getting Worse FPS with Newer Computer!?

    I tried to do the whole nVidia control panel thing, but could never find "javaw.exe." When I tried to change the computer's display setting to 1080p it really screwed with thing. I still don't know how my other computer ran beautifully at 60 FPS and I never, ever messed with any of these things.



    Install Optifine, set fullscreen resolution to 1920x1080 (or the highest resolution that your computer can play smoothly). Your problem isn't really your new computer, it's the lack of configuration of the game that's making it run at the native 4k resolution of your display which of course is going to lower your frame rate. HiDPI displays found in most new laptops are fantastic for productivity and everyday computing, but they do need a little configuration to get playable frame rates while gaming, especially with most non-gaming laptops not having a ton of GPU power.

    Posted in: Java Edition Support
  • 0

    posted a message on [1.14] Chocapic13's Shaders
    Quote from Linndolas»
    Also, in Linux Mint 18 or for example Ubuntu 16.04 and up, if you have a radeon graphics card you can only use open source drivers now.
    So yeah, that's probably the reason for compatibilty issues.



    Not likely. Shaders rarely work at all on any platform unless the developer is developing on that platform specifically. For example, chocapic13's shaders rarely work on Macs because AFAIK Chocapic13 mainly works in Windows. And yShaders (back when I still did that) was primarily compatible with Macs running Intel Graphics because that's what I was developing it on.

    Posted in: Minecraft Mods
  • 1

    posted a message on [1.14] Chocapic13's Shaders

    sensi277, will you continue "yShaders" on the upcoming V6? Just asking, not forcing.


    Nope. Chocapic13 is already doing a pretty good job at making his shaders more lightweight.
    Posted in: Minecraft Mods
  • 1

    posted a message on [1.14] Chocapic13's Shaders

    What is POM, it is Parallax Occulusion Mapping I know, but what does it do? i'm asking these because i'm not familiar with POM.

    I have a question:


    It's basically a low-cost way for texture packs to implement a depth map alongside their textures, giving the illusion of depth without using 3D models or increasing needed processing power by a whole lot.


    Edit: This blog post by game developer Shamus Young explains it pretty well: http://www.shamusyoung.com/twentysidedtale/?p=23513

    Posted in: Minecraft Mods
  • 1

    posted a message on [1.14] Chocapic13's Shaders

    Did chocapic13 uses SEUS as a base before? I didn't reach that.



    He did, in v3 and below. In v4 he re-wrote the entire shader pack to comply with SEUS's terms and conditions.

    Posted in: Minecraft Mods
  • 0

    posted a message on [1.14] Chocapic13's Shaders
    Quote from Triliton»

    Its not compatible with MAC.


    One of chocapic13's goals for final v6 is that it will be compatible with Macs. It's always been this way. v4 was (at least supposed to be) supported on Macs, same with v5. Compatibility wasn't always great but it was at least there.

    Posted in: Minecraft Mods
  • 0

    posted a message on [1.14] Chocapic13's Shaders


    I've never been on a MAC before. Here are some questions:
    Did you update everything?
    Does this also happen on OTHER shaderpacks?

    I think a guy named grimallaq, said something like "Thank you MAC for breaking OpenGL Support", well something like that.
    Does this happens to your discontinued project, yShaders?


    And also, can you send your log in a spoiler?



    Did I update everything? Yes. macOS 10.12 is the latest version of macOS. Apple updates everything (including graphics drivers) with the OS.
    Does this happen with other shader packs? No.

    macOS definitely does have a weird OpenGL implementation with their graphics drivers, which makes it really weird and difficult to develop shaders for Mac unless you know the quirks of Apple's OpenGL implementation. That being said, it's not impossible, if I remember correctly Chocapic13's v4 shaders was fully Mac compatible, as is Sildur's Vibrant shaders and others.

    Does this happen with yShaders? No, yShaders works just fine (actually still better performance than any other shader pack I've tried on this computer), as does Sildur's Vibrant Shaders.

    Here is my log:



    [Shaders] ShadersMod version: 2.4.12
    [Shaders] OpenGL Version: 2.1 ATI-1.44.68
    [Shaders] Vendor: ATI Technologies Inc.
    [Shaders] Renderer: AMD Radeon R9 M395X OpenGL Engine
    [Shaders] Capabilities: 2.0 2.1 - - -
    [Shaders] GL_MAX_DRAW_BUFFERS: 8
    [Shaders] GL_MAX_COLOR_ATTACHMENTS_EXT: 8
    [Shaders] GL_MAX_TEXTURE_IMAGE_UNITS: 16
    [Shaders] Load ShadersMod configuration.
    [Shaders] No shaderpack loaded.
    [Shaders] Loaded shaderpack: Chocapic13 V6 Extreme RC.zip
    [Shaders] allocateTextureMap 4 1024 512
    [Shaders][SEVERE] Error compiling vertex shader: /shaders/gbuffers_basic.vsh
    [Shaders] Shader info log: /shaders/gbuffers_basic.vsh
    ERROR: 0:1: '' : version '400' is not supported
    ERROR: 0:1: '' : syntax error: #version
    ERROR: 0:10: 'flat' : syntax error: syntax error

    [Shaders] composite format: RGBA16
    [Shaders] gaux2 format: RGBA16
    [Shaders] gaux3 format: RGBA16
    [Shaders] gaux4 format: RGBA16
    [Shaders] gcolor format: RGBA8
    [Shaders] gdepth format: RGBA16
    [Shaders] gnormal format: RGBA16
    [Shaders] composite format: R11F_G11F_B10F
    [Shaders] gaux1 format: RGBA16
    [Shaders] gaux2 format: R11F_G11F_B10F
    [Shaders] gaux3 format: R11F_G11F_B10F
    [Shaders] gaux4 format: R11F_G11F_B10F
    [Shaders][SEVERE] Error compiling fragment shader: /shaders/gbuffers_basic.fsh
    [Shaders] Shader info log: /shaders/gbuffers_basic.fsh
    ERROR: 0:1: '' : version '400' is not supported
    ERROR: 0:1: '' : syntax error: #version
    ERROR: 0:27: 'flat' : syntax error: syntax error

    [Shaders][SEVERE] Error linking program: 14
    [Shaders] Info log: /shaders/gbuffers_basic.vsh, /shaders/gbuffers_basic.fsh
    ERROR: One or more attached shaders not successfully compiled

    [Shaders] Info log: /shaders/gbuffers_basic.vsh, /shaders/gbuffers_basic.fsh
    Validation Failed: Link error:
    Program is not successfully linked.

    [Shaders][SEVERE] [Shaders] Error: Invalid program "gbuffers_basic"
    [Shaders][SEVERE] Error compiling vertex shader: /shaders/gbuffers_textured.vsh
    [Shaders] Shader info log: /shaders/gbuffers_textured.vsh
    ERROR: 0:1: '' : version '400' is not supported
    ERROR: 0:1: '' : syntax error: #version
    ERROR: 0:72: '(' : syntax error: Array size must appear after variable name

    [Shaders][SEVERE] Error compiling fragment shader: /shaders/gbuffers_textured.fsh
    [Shaders] Shader info log: /shaders/gbuffers_textured.fsh
    ERROR: 0:1: '' : version '400' is not supported
    ERROR: 0:1: '' : syntax error: #version
    ERROR: 0:11: '(' : syntax error: Array size must appear after variable name

    [Shaders][SEVERE] Error linking program: 14
    [Shaders] Info log: /shaders/gbuffers_textured.vsh, /shaders/gbuffers_textured.fsh
    ERROR: One or more attached shaders not successfully compiled

    [Shaders] Info log: /shaders/gbuffers_textured.vsh, /shaders/gbuffers_textured.fsh
    Validation Failed: Link error:
    Program is not successfully linked.

    [Shaders][SEVERE] [Shaders] Error: Invalid program "gbuffers_textured"
    [Shaders][SEVERE] Error compiling vertex shader: /shaders/gbuffers_textured_lit.vsh
    [Shaders] Shader info log: /shaders/gbuffers_textured_lit.vsh
    ERROR: 0:1: '' : version '400' is not supported
    ERROR: 0:1: '' : syntax error: #version

    [Shaders][SEVERE] Error compiling fragment shader: /shaders/gbuffers_textured_lit.fsh
    [Shaders] Shader info log: /shaders/gbuffers_textured_lit.fsh
    ERROR: 0:1: '' : version '400' is not supported
    ERROR: 0:1: '' : syntax error: #version

    [Shaders][SEVERE] Error linking program: 14
    [Shaders] Info log: /shaders/gbuffers_textured_lit.vsh, /shaders/gbuffers_textured_lit.fsh
    ERROR: One or more attached shaders not successfully compiled

    [Shaders] Info log: /shaders/gbuffers_textured_lit.vsh, /shaders/gbuffers_textured_lit.fsh
    Validation Failed: Link error:
    Program is not successfully linked.

    [Shaders][SEVERE] [Shaders] Error: Invalid program "gbuffers_textured_lit"
    [Shaders][SEVERE] Error compiling vertex shader: /shaders/gbuffers_skybasic.vsh
    [Shaders] Shader info log: /shaders/gbuffers_skybasic.vsh
    ERROR: 0:1: '' : version '400' is not supported
    ERROR: 0:1: '' : syntax error: #version

    [Shaders][SEVERE] Error compiling fragment shader: /shaders/gbuffers_skybasic.fsh
    [Shaders] Shader info log: /shaders/gbuffers_skybasic.fsh
    ERROR: 0:1: '' : version '400' is not supported
    ERROR: 0:1: '' : syntax error: #version

    [Shaders][SEVERE] Error linking program: 14
    [Shaders] Info log: /shaders/gbuffers_skybasic.vsh, /shaders/gbuffers_skybasic.fsh
    ERROR: One or more attached shaders not successfully compiled

    [Shaders] Info log: /shaders/gbuffers_skybasic.vsh, /shaders/gbuffers_skybasic.fsh
    Validation Failed: Link error:
    Program is not successfully linked.

    [Shaders][SEVERE] [Shaders] Error: Invalid program "gbuffers_skybasic"
    [Shaders][SEVERE] Error compiling vertex shader: /shaders/gbuffers_skytextured.vsh
    [Shaders] Shader info log: /shaders/gbuffers_skytextured.vsh
    ERROR: 0:1: '' : version '400' is not supported
    ERROR: 0:1: '' : syntax error: #version

    [Shaders][SEVERE] Error compiling fragment shader: /shaders/gbuffers_skytextured.fsh
    [Shaders] Shader info log: /shaders/gbuffers_skytextured.fsh
    ERROR: 0:1: '' : version '400' is not supported
    ERROR: 0:1: '' : syntax error: #version

    [Shaders][SEVERE] Error linking program: 14
    [Shaders] Info log: /shaders/gbuffers_skytextured.vsh, /shaders/gbuffers_skytextured.fsh
    ERROR: One or more attached shaders not successfully compiled

    [Shaders] Info log: /shaders/gbuffers_skytextured.vsh, /shaders/gbuffers_skytextured.fsh
    Validation Failed: Link error:
    Program is not successfully linked.

    [Shaders][SEVERE] [Shaders] Error: Invalid program "gbuffers_skytextured"
    [Shaders][SEVERE] Error compiling vertex shader: /shaders/gbuffers_terrain.vsh
    [Shaders] Shader info log: /shaders/gbuffers_terrain.vsh
    ERROR: 0:1: '' : version '400' is not supported
    ERROR: 0:1: '' : syntax error: #version
    ERROR: 0:90: 'switch' : Reserved word.
    ERROR: 0:90: 'switch' : syntax error: syntax error

    [Shaders] composite format: RGBA16
    [Shaders] gaux2 format: RGBA16
    [Shaders] gaux3 format: RGBA16
    [Shaders] gaux4 format: RGBA16
    [Shaders] gcolor format: RGBA8
    [Shaders] gdepth format: RGBA16
    [Shaders] gnormal format: RGBA16
    [Shaders] composite format: R11F_G11F_B10F
    [Shaders] gaux1 format: RGBA16
    [Shaders] gaux2 format: R11F_G11F_B10F
    [Shaders] gaux3 format: R11F_G11F_B10F
    [Shaders] gaux4 format: R11F_G11F_B10F
    [Shaders][SEVERE] Error compiling fragment shader: /shaders/gbuffers_terrain.fsh
    [Shaders] Shader info log: /shaders/gbuffers_terrain.fsh
    ERROR: 0:1: '' : version '400' is not supported
    ERROR: 0:1: '' : syntax error: #version

    [Shaders][SEVERE] Error linking program: 14
    [Shaders] Info log: /shaders/gbuffers_terrain.vsh, /shaders/gbuffers_terrain.fsh
    ERROR: One or more attached shaders not successfully compiled

    [Shaders] Info log: /shaders/gbuffers_terrain.vsh, /shaders/gbuffers_terrain.fsh
    Validation Failed: Link error:
    Program is not successfully linked.

    [Shaders][SEVERE] [Shaders] Error: Invalid program "gbuffers_terrain"
    [Shaders][SEVERE] Error compiling vertex shader: /shaders/gbuffers_water.vsh
    [Shaders] Shader info log: /shaders/gbuffers_water.vsh
    ERROR: 0:1: '' : version '400' is not supported
    ERROR: 0:1: '' : syntax error: #version
    ERROR: 0:71: '(' : syntax error: Array size must appear after variable name

    [Shaders][SEVERE] Error compiling fragment shader: /shaders/gbuffers_water.fsh
    [Shaders] Shader info log: /shaders/gbuffers_water.fsh
    ERROR: 0:1: '' : version '400' is not supported
    ERROR: 0:1: '' : syntax error: #version
    ERROR: 0:52: '(' : syntax error: Array size must appear after variable name

    [Shaders][SEVERE] Error linking program: 14
    [Shaders] Info log: /shaders/gbuffers_water.vsh, /shaders/gbuffers_water.fsh
    ERROR: One or more attached shaders not successfully compiled

    [Shaders] Info log: /shaders/gbuffers_water.vsh, /shaders/gbuffers_water.fsh
    Validation Failed: Link error:
    Program is not successfully linked.

    [Shaders][SEVERE] [Shaders] Error: Invalid program "gbuffers_water"
    [Shaders][SEVERE] Error compiling vertex shader: /shaders/gbuffers_entities.vsh
    [Shaders] Shader info log: /shaders/gbuffers_entities.vsh
    ERROR: 0:1: '' : version '400' is not supported
    ERROR: 0:1: '' : syntax error: #version

    [Shaders][SEVERE] Error compiling fragment shader: /shaders/gbuffers_entities.fsh
    [Shaders] Shader info log: /shaders/gbuffers_entities.fsh
    ERROR: 0:1: '' : version '400' is not supported
    ERROR: 0:1: '' : syntax error: #version

    [Shaders][SEVERE] Error linking program: 14
    [Shaders] Info log: /shaders/gbuffers_entities.vsh, /shaders/gbuffers_entities.fsh
    ERROR: One or more attached shaders not successfully compiled

    [Shaders] Info log: /shaders/gbuffers_entities.vsh, /shaders/gbuffers_entities.fsh
    Validation Failed: Link error:
    Program is not successfully linked.

    [Shaders][SEVERE] [Shaders] Error: Invalid program "gbuffers_entities"
    [Shaders][SEVERE] Error compiling vertex shader: /shaders/gbuffers_hand.vsh
    [Shaders] Shader info log: /shaders/gbuffers_hand.vsh
    ERROR: 0:1: '' : version '400' is not supported
    ERROR: 0:1: '' : syntax error: #version
    ERROR: 0:71: '(' : syntax error: Array size must appear after variable name

    [Shaders][SEVERE] Error compiling fragment shader: /shaders/gbuffers_hand.fsh
    [Shaders] Shader info log: /shaders/gbuffers_hand.fsh
    ERROR: 0:1: '' : version '400' is not supported
    ERROR: 0:1: '' : syntax error: #version
    ERROR: 0:11: '(' : syntax error: Array size must appear after variable name

    [Shaders][SEVERE] Error linking program: 14
    [Shaders] Info log: /shaders/gbuffers_hand.vsh, /shaders/gbuffers_hand.fsh
    ERROR: One or more attached shaders not successfully compiled

    [Shaders] Info log: /shaders/gbuffers_hand.vsh, /shaders/gbuffers_hand.fsh
    Validation Failed: Link error:
    Program is not successfully linked.

    [Shaders][SEVERE] [Shaders] Error: Invalid program "gbuffers_hand"
    [Shaders][SEVERE] Error compiling vertex shader: /shaders/gbuffers_weather.vsh
    [Shaders] Shader info log: /shaders/gbuffers_weather.vsh
    ERROR: 0:1: '' : version '400' is not supported
    ERROR: 0:1: '' : syntax error: #version
    ERROR: 0:50: '(' : syntax error: Array size must appear after variable name

    [Shaders][SEVERE] Error compiling fragment shader: /shaders/gbuffers_weather.fsh
    [Shaders] Shader info log: /shaders/gbuffers_weather.fsh
    ERROR: 0:1: '' : version '400' is not supported
    ERROR: 0:1: '' : syntax error: #version

    [Shaders][SEVERE] Error linking program: 14
    [Shaders] Info log: /shaders/gbuffers_weather.vsh, /shaders/gbuffers_weather.fsh
    ERROR: One or more attached shaders not successfully compiled

    [Shaders] Info log: /shaders/gbuffers_weather.vsh, /shaders/gbuffers_weather.fsh
    Validation Failed: Link error:
    Program is not successfully linked.

    [Shaders][SEVERE] [Shaders] Error: Invalid program "gbuffers_weather"
    [Shaders][SEVERE] Error compiling vertex shader: /shaders/composite.vsh
    [Shaders] Shader info log: /shaders/composite.vsh
    ERROR: 0:1: '' : version '400' is not supported
    ERROR: 0:1: '' : syntax error: #version
    ERROR: 0:123: '(' : syntax error: Array size must appear after variable name

    [Shaders] Noise texture enabled
    [Shaders] Noise texture resolution: 1024
    [Shaders][SEVERE] Error compiling fragment shader: /shaders/composite.fsh
    [Shaders] Shader info log: /shaders/composite.fsh
    ERROR: 0:1: '' : version '400' is not supported
    ERROR: 0:1: '' : syntax error: #version
    ERROR: 0:155: '(' : syntax error: Array size must appear after variable name

    [Shaders][SEVERE] Error linking program: 14
    [Shaders] Info log: /shaders/composite.vsh, /shaders/composite.fsh
    ERROR: One or more attached shaders not successfully compiled

    [Shaders] Info log: /shaders/composite.vsh, /shaders/composite.fsh
    Validation Failed: Link error:
    Program is not successfully linked.

    [Shaders][SEVERE] [Shaders] Error: Invalid program "composite"
    [Shaders][SEVERE] Error compiling vertex shader: /shaders/composite1.vsh
    [Shaders] Shader info log: /shaders/composite1.vsh
    ERROR: 0:1: '' : version '400' is not supported
    ERROR: 0:1: '' : syntax error: #version
    ERROR: 0:123: '(' : syntax error: Array size must appear after variable name

    [Shaders] Noise texture enabled
    [Shaders] Noise texture resolution: 1024
    [Shaders][SEVERE] Error compiling fragment shader: /shaders/composite1.fsh
    [Shaders] Shader info log: /shaders/composite1.fsh
    ERROR: 0:1: '' : version '400' is not supported
    ERROR: 0:1: '' : syntax error: #version
    ERROR: 0:136: '(' : syntax error: Array size must appear after variable name

    [Shaders][SEVERE] Error linking program: 14
    [Shaders] Info log: /shaders/composite1.vsh, /shaders/composite1.fsh
    ERROR: One or more attached shaders not successfully compiled

    [Shaders] Info log: /shaders/composite1.vsh, /shaders/composite1.fsh
    Validation Failed: Link error:
    Program is not successfully linked.

    [Shaders][SEVERE] [Shaders] Error: Invalid program "composite1"
    [Shaders][SEVERE] Error compiling vertex shader: /shaders/composite2.vsh
    [Shaders] Shader info log: /shaders/composite2.vsh
    ERROR: 0:1: '' : version '400' is not supported
    ERROR: 0:1: '' : syntax error: #version
    ERROR: 0:123: '(' : syntax error: Array size must appear after variable name

    [Shaders] Shadow map resolution: 4096
    [Shaders] Shadow map distance: 140.0
    [Shaders] shadowHardwareFiltering0
    [Shaders] Sun path rotation: -40.0f
    [Shaders] Noise texture enabled
    [Shaders] Noise texture resolution: 1024
    [Shaders][SEVERE] Error compiling fragment shader: /shaders/composite2.fsh
    [Shaders] Shader info log: /shaders/composite2.fsh
    ERROR: 0:1: '' : version '400' is not supported
    ERROR: 0:1: '' : syntax error: #version
    ERROR: 0:5: 'f' : syntax error: syntax error

    [Shaders][SEVERE] Error linking program: 14
    [Shaders] Info log: /shaders/composite2.vsh, /shaders/composite2.fsh
    ERROR: One or more attached shaders not successfully compiled

    [Shaders] Info log: /shaders/composite2.vsh, /shaders/composite2.fsh
    Validation Failed: Link error:
    Program is not successfully linked.

    [Shaders][SEVERE] [Shaders] Error: Invalid program "composite2"
    [Shaders][SEVERE] Error compiling vertex shader: /shaders/composite3.vsh
    [Shaders] Shader info log: /shaders/composite3.vsh
    ERROR: 0:1: '' : version '400' is not supported
    ERROR: 0:1: '' : syntax error: #version
    ERROR: 0:124: '(' : syntax error: Array size must appear after variable name

    [Shaders] gaux1 mipmap enabled for /shaders/composite3.fsh
    [Shaders][SEVERE] Error compiling fragment shader: /shaders/composite3.fsh
    [Shaders] Shader info log: /shaders/composite3.fsh
    ERROR: 0:1: '' : version '400' is not supported
    ERROR: 0:1: '' : syntax error: #version
    ERROR: 0:424: '(' : syntax error: Array size must appear after variable name

    [Shaders][SEVERE] Error linking program: 14
    [Shaders] Info log: /shaders/composite3.vsh, /shaders/composite3.fsh
    ERROR: One or more attached shaders not successfully compiled

    [Shaders] Info log: /shaders/composite3.vsh, /shaders/composite3.fsh
    Validation Failed: Link error:
    Program is not successfully linked.

    [Shaders][SEVERE] [Shaders] Error: Invalid program "composite3"
    [Shaders][SEVERE] Error compiling vertex shader: /shaders/composite4.vsh
    [Shaders] Shader info log: /shaders/composite4.vsh
    ERROR: 0:1: '' : version '400' is not supported
    ERROR: 0:1: '' : syntax error: #version
    ERROR: 0:131: '(' : syntax error: Array size must appear after variable name

    [Shaders][SEVERE] Error compiling fragment shader: /shaders/composite4.fsh
    [Shaders] Shader info log: /shaders/composite4.fsh
    ERROR: 0:1: '' : version '400' is not supported
    ERROR: 0:1: '' : syntax error: #version

    [Shaders][SEVERE] Error linking program: 14
    [Shaders] Info log: /shaders/composite4.vsh, /shaders/composite4.fsh
    ERROR: One or more attached shaders not successfully compiled

    [Shaders] Info log: /shaders/composite4.vsh, /shaders/composite4.fsh
    Validation Failed: Link error:
    Program is not successfully linked.

    [Shaders][SEVERE] [Shaders] Error: Invalid program "composite4"
    [Shaders][SEVERE] Error compiling vertex shader: /shaders/composite5.vsh
    [Shaders] Shader info log: /shaders/composite5.vsh
    ERROR: 0:1: '' : version '400' is not supported
    ERROR: 0:1: '' : syntax error: #version
    ERROR: 0:131: '(' : syntax error: Array size must appear after variable name

    [Shaders][SEVERE] Error compiling fragment shader: /shaders/composite5.fsh
    [Shaders] Shader info log: /shaders/composite5.fsh
    ERROR: 0:1: '' : version '400' is not supported
    ERROR: 0:1: '' : syntax error: #version

    [Shaders][SEVERE] Error linking program: 14
    [Shaders] Info log: /shaders/composite5.vsh, /shaders/composite5.fsh
    ERROR: One or more attached shaders not successfully compiled

    [Shaders] Info log: /shaders/composite5.vsh, /shaders/composite5.fsh
    Validation Failed: Link error:
    Program is not successfully linked.

    [Shaders][SEVERE] [Shaders] Error: Invalid program "composite5"
    [Shaders][SEVERE] Error compiling vertex shader: /shaders/final.vsh
    [Shaders] Shader info log: /shaders/final.vsh
    ERROR: 0:1: '' : version '400' is not supported
    ERROR: 0:1: '' : syntax error: #version
    ERROR: 0:131: '(' : syntax error: Array size must appear after variable name

    [Shaders][SEVERE] Error compiling fragment shader: /shaders/final.fsh
    [Shaders] Shader info log: /shaders/final.fsh
    ERROR: 0:1: '' : version '400' is not supported
    ERROR: 0:1: '' : syntax error: #version

    [Shaders][SEVERE] Error linking program: 14
    [Shaders] Info log: /shaders/final.vsh, /shaders/final.fsh
    ERROR: One or more attached shaders not successfully compiled

    [Shaders] Info log: /shaders/final.vsh, /shaders/final.fsh
    Validation Failed: Link error:
    Program is not successfully linked.

    [Shaders][SEVERE] [Shaders] Error: Invalid program "final"
    [Shaders][SEVERE] Error compiling vertex shader: /shaders/shadow.vsh
    [Shaders] Shader info log: /shaders/shadow.vsh
    ERROR: 0:1: '' : version '400' is not supported
    ERROR: 0:1: '' : syntax error: #version
    ERROR: 0:105: 'switch' : Reserved word.
    ERROR: 0:105: 'switch' : syntax error: syntax error

    [Shaders][SEVERE] Error compiling fragment shader: /shaders/shadow.fsh
    [Shaders] Shader info log: /shaders/shadow.fsh
    ERROR: 0:1: '' : version '400' is not supported
    ERROR: 0:1: '' : syntax error: #version

    [Shaders][SEVERE] Error linking program: 14
    [Shaders] Info log: /shaders/shadow.vsh, /shaders/shadow.fsh
    ERROR: One or more attached shaders not successfully compiled

    [Shaders] Info log: /shaders/shadow.vsh, /shaders/shadow.fsh
    Validation Failed: Link error:
    Program is not successfully linked.

    [Shaders][SEVERE] [Shaders] Error: Invalid program "shadow"
    [Shaders] usedColorBuffers: 8
    [Shaders] usedDepthBuffers: 2
    [Shaders] usedShadowColorBuffers: 0
    [Shaders] usedShadowDepthBuffers: 2
    [Shaders] usedColorAttachs: 8
    [Shaders] usedDrawBuffers: 1
    [Shaders] Framebuffer created.
    [Shaders] Shadow framebuffer created.
    [Shaders] Reset world renderers
    [Shaders] Reset model renderers
    [Shaders] Loaded shaderpack: Chocapic13 V6 Extreme RC.zip
    [Shaders] Uninit
    [Shaders][SEVERE] Error compiling vertex shader: /shaders/gbuffers_basic.vsh
    [Shaders] Shader info log: /shaders/gbuffers_basic.vsh
    ERROR: 0:1: '' : version '400' is not supported
    ERROR: 0:1: '' : syntax error: #version
    ERROR: 0:10: 'flat' : syntax error: syntax error

    [Shaders] composite format: RGBA16
    [Shaders] gaux2 format: RGBA16
    [Shaders] gaux3 format: RGBA16
    [Shaders] gaux4 format: RGBA16
    [Shaders] gcolor format: RGBA8
    [Shaders] gdepth format: RGBA16
    [Shaders] gnormal format: RGBA16
    [Shaders] composite format: R11F_G11F_B10F
    [Shaders] gaux1 format: RGBA16
    [Shaders] gaux2 format: R11F_G11F_B10F
    [Shaders] gaux3 format: R11F_G11F_B10F
    [Shaders] gaux4 format: R11F_G11F_B10F
    [Shaders][SEVERE] Error compiling fragment shader: /shaders/gbuffers_basic.fsh
    [Shaders] Shader info log: /shaders/gbuffers_basic.fsh
    ERROR: 0:1: '' : version '400' is not supported
    ERROR: 0:1: '' : syntax error: #version
    ERROR: 0:27: 'flat' : syntax error: syntax error

    [Shaders][SEVERE] Error linking program: 14
    [Shaders] Info log: /shaders/gbuffers_basic.vsh, /shaders/gbuffers_basic.fsh
    ERROR: One or more attached shaders not successfully compiled

    [Shaders] Info log: /shaders/gbuffers_basic.vsh, /shaders/gbuffers_basic.fsh
    Validation Failed: Link error:
    Program is not successfully linked.

    [Shaders][SEVERE] [Shaders] Error: Invalid program "gbuffers_basic"
    [Shaders][SEVERE] Error compiling vertex shader: /shaders/gbuffers_textured.vsh
    [Shaders] Shader info log: /shaders/gbuffers_textured.vsh
    ERROR: 0:1: '' : version '400' is not supported
    ERROR: 0:1: '' : syntax error: #version
    ERROR: 0:72: '(' : syntax error: Array size must appear after variable name

    [Shaders][SEVERE] Error compiling fragment shader: /shaders/gbuffers_textured.fsh
    [Shaders] Shader info log: /shaders/gbuffers_textured.fsh
    ERROR: 0:1: '' : version '400' is not supported
    ERROR: 0:1: '' : syntax error: #version
    ERROR: 0:11: '(' : syntax error: Array size must appear after variable name

    [Shaders][SEVERE] Error linking program: 14
    [Shaders] Info log: /shaders/gbuffers_textured.vsh, /shaders/gbuffers_textured.fsh
    ERROR: One or more attached shaders not successfully compiled

    [Shaders] Info log: /shaders/gbuffers_textured.vsh, /shaders/gbuffers_textured.fsh
    Validation Failed: Link error:
    Program is not successfully linked.

    [Shaders][SEVERE] [Shaders] Error: Invalid program "gbuffers_textured"
    [Shaders][SEVERE] Error compiling vertex shader: /shaders/gbuffers_textured_lit.vsh
    [Shaders] Shader info log: /shaders/gbuffers_textured_lit.vsh
    ERROR: 0:1: '' : version '400' is not supported
    ERROR: 0:1: '' : syntax error: #version

    [Shaders][SEVERE] Error compiling fragment shader: /shaders/gbuffers_textured_lit.fsh
    [Shaders] Shader info log: /shaders/gbuffers_textured_lit.fsh
    ERROR: 0:1: '' : version '400' is not supported
    ERROR: 0:1: '' : syntax error: #version

    [Shaders][SEVERE] Error linking program: 14
    [Shaders] Info log: /shaders/gbuffers_textured_lit.vsh, /shaders/gbuffers_textured_lit.fsh
    ERROR: One or more attached shaders not successfully compiled

    [Shaders] Info log: /shaders/gbuffers_textured_lit.vsh, /shaders/gbuffers_textured_lit.fsh
    Validation Failed: Link error:
    Program is not successfully linked.

    [Shaders][SEVERE] [Shaders] Error: Invalid program "gbuffers_textured_lit"
    [Shaders][SEVERE] Error compiling vertex shader: /shaders/gbuffers_skybasic.vsh
    [Shaders] Shader info log: /shaders/gbuffers_skybasic.vsh
    ERROR: 0:1: '' : version '400' is not supported
    ERROR: 0:1: '' : syntax error: #version

    [Shaders][SEVERE] Error compiling fragment shader: /shaders/gbuffers_skybasic.fsh
    [Shaders] Shader info log: /shaders/gbuffers_skybasic.fsh
    ERROR: 0:1: '' : version '400' is not supported
    ERROR: 0:1: '' : syntax error: #version

    [Shaders][SEVERE] Error linking program: 14
    [Shaders] Info log: /shaders/gbuffers_skybasic.vsh, /shaders/gbuffers_skybasic.fsh
    ERROR: One or more attached shaders not successfully compiled

    [Shaders] Info log: /shaders/gbuffers_skybasic.vsh, /shaders/gbuffers_skybasic.fsh
    Validation Failed: Link error:
    Program is not successfully linked.

    [Shaders][SEVERE] [Shaders] Error: Invalid program "gbuffers_skybasic"
    [Shaders][SEVERE] Error compiling vertex shader: /shaders/gbuffers_skytextured.vsh
    [Shaders] Shader info log: /shaders/gbuffers_skytextured.vsh
    ERROR: 0:1: '' : version '400' is not supported
    ERROR: 0:1: '' : syntax error: #version

    [Shaders][SEVERE] Error compiling fragment shader: /shaders/gbuffers_skytextured.fsh
    [Shaders] Shader info log: /shaders/gbuffers_skytextured.fsh
    ERROR: 0:1: '' : version '400' is not supported
    ERROR: 0:1: '' : syntax error: #version

    [Shaders][SEVERE] Error linking program: 14
    [Shaders] Info log: /shaders/gbuffers_skytextured.vsh, /shaders/gbuffers_skytextured.fsh
    ERROR: One or more attached shaders not successfully compiled

    [Shaders] Info log: /shaders/gbuffers_skytextured.vsh, /shaders/gbuffers_skytextured.fsh
    Validation Failed: Link error:
    Program is not successfully linked.

    [Shaders][SEVERE] [Shaders] Error: Invalid program "gbuffers_skytextured"
    [Shaders][SEVERE] Error compiling vertex shader: /shaders/gbuffers_terrain.vsh
    [Shaders] Shader info log: /shaders/gbuffers_terrain.vsh
    ERROR: 0:1: '' : version '400' is not supported
    ERROR: 0:1: '' : syntax error: #version
    ERROR: 0:90: 'switch' : Reserved word.
    ERROR: 0:90: 'switch' : syntax error: syntax error

    [Shaders] composite format: RGBA16
    [Shaders] gaux2 format: RGBA16
    [Shaders] gaux3 format: RGBA16
    [Shaders] gaux4 format: RGBA16
    [Shaders] gcolor format: RGBA8
    [Shaders] gdepth format: RGBA16
    [Shaders] gnormal format: RGBA16
    [Shaders] composite format: R11F_G11F_B10F
    [Shaders] gaux1 format: RGBA16
    [Shaders] gaux2 format: R11F_G11F_B10F
    [Shaders] gaux3 format: R11F_G11F_B10F
    [Shaders] gaux4 format: R11F_G11F_B10F
    [Shaders][SEVERE] Error compiling fragment shader: /shaders/gbuffers_terrain.fsh
    [Shaders] Shader info log: /shaders/gbuffers_terrain.fsh
    ERROR: 0:1: '' : version '400' is not supported
    ERROR: 0:1: '' : syntax error: #version

    [Shaders][SEVERE] Error linking program: 14
    [Shaders] Info log: /shaders/gbuffers_terrain.vsh, /shaders/gbuffers_terrain.fsh
    ERROR: One or more attached shaders not successfully compiled

    [Shaders] Info log: /shaders/gbuffers_terrain.vsh, /shaders/gbuffers_terrain.fsh
    Validation Failed: Link error:
    Program is not successfully linked.

    [Shaders][SEVERE] [Shaders] Error: Invalid program "gbuffers_terrain"
    [Shaders][SEVERE] Error compiling vertex shader: /shaders/gbuffers_water.vsh
    [Shaders] Shader info log: /shaders/gbuffers_water.vsh
    ERROR: 0:1: '' : version '400' is not supported
    ERROR: 0:1: '' : syntax error: #version
    ERROR: 0:71: '(' : syntax error: Array size must appear after variable name

    [Shaders][SEVERE] Error compiling fragment shader: /shaders/gbuffers_water.fsh
    [Shaders] Shader info log: /shaders/gbuffers_water.fsh
    ERROR: 0:1: '' : version '400' is not supported
    ERROR: 0:1: '' : syntax error: #version
    ERROR: 0:52: '(' : syntax error: Array size must appear after variable name

    [Shaders][SEVERE] Error linking program: 14
    [Shaders] Info log: /shaders/gbuffers_water.vsh, /shaders/gbuffers_water.fsh
    ERROR: One or more attached shaders not successfully compiled

    [Shaders] Info log: /shaders/gbuffers_water.vsh, /shaders/gbuffers_water.fsh
    Validation Failed: Link error:
    Program is not successfully linked.

    [Shaders][SEVERE] [Shaders] Error: Invalid program "gbuffers_water"
    [Shaders][SEVERE] Error compiling vertex shader: /shaders/gbuffers_entities.vsh
    [Shaders] Shader info log: /shaders/gbuffers_entities.vsh
    ERROR: 0:1: '' : version '400' is not supported
    ERROR: 0:1: '' : syntax error: #version

    [Shaders][SEVERE] Error compiling fragment shader: /shaders/gbuffers_entities.fsh
    [Shaders] Shader info log: /shaders/gbuffers_entities.fsh
    ERROR: 0:1: '' : version '400' is not supported
    ERROR: 0:1: '' : syntax error: #version

    [Shaders][SEVERE] Error linking program: 14
    [Shaders] Info log: /shaders/gbuffers_entities.vsh, /shaders/gbuffers_entities.fsh
    ERROR: One or more attached shaders not successfully compiled

    [Shaders] Info log: /shaders/gbuffers_entities.vsh, /shaders/gbuffers_entities.fsh
    Validation Failed: Link error:
    Program is not successfully linked.

    [Shaders][SEVERE] [Shaders] Error: Invalid program "gbuffers_entities"
    [Shaders][SEVERE] Error compiling vertex shader: /shaders/gbuffers_hand.vsh
    [Shaders] Shader info log: /shaders/gbuffers_hand.vsh
    ERROR: 0:1: '' : version '400' is not supported
    ERROR: 0:1: '' : syntax error: #version
    ERROR: 0:71: '(' : syntax error: Array size must appear after variable name

    [Shaders][SEVERE] Error compiling fragment shader: /shaders/gbuffers_hand.fsh
    [Shaders] Shader info log: /shaders/gbuffers_hand.fsh
    ERROR: 0:1: '' : version '400' is not supported
    ERROR: 0:1: '' : syntax error: #version
    ERROR: 0:11: '(' : syntax error: Array size must appear after variable name

    [Shaders][SEVERE] Error linking program: 14
    [Shaders] Info log: /shaders/gbuffers_hand.vsh, /shaders/gbuffers_hand.fsh
    ERROR: One or more attached shaders not successfully compiled

    [Shaders] Info log: /shaders/gbuffers_hand.vsh, /shaders/gbuffers_hand.fsh
    Validation Failed: Link error:
    Program is not successfully linked.

    [Shaders][SEVERE] [Shaders] Error: Invalid program "gbuffers_hand"
    [Shaders][SEVERE] Error compiling vertex shader: /shaders/gbuffers_weather.vsh
    [Shaders] Shader info log: /shaders/gbuffers_weather.vsh
    ERROR: 0:1: '' : version '400' is not supported
    ERROR: 0:1: '' : syntax error: #version
    ERROR: 0:50: '(' : syntax error: Array size must appear after variable name

    [Shaders][SEVERE] Error compiling fragment shader: /shaders/gbuffers_weather.fsh
    [Shaders] Shader info log: /shaders/gbuffers_weather.fsh
    ERROR: 0:1: '' : version '400' is not supported
    ERROR: 0:1: '' : syntax error: #version

    [Shaders][SEVERE] Error linking program: 14
    [Shaders] Info log: /shaders/gbuffers_weather.vsh, /shaders/gbuffers_weather.fsh
    ERROR: One or more attached shaders not successfully compiled

    [Shaders] Info log: /shaders/gbuffers_weather.vsh, /shaders/gbuffers_weather.fsh
    Validation Failed: Link error:
    Program is not successfully linked.

    [Shaders][SEVERE] [Shaders] Error: Invalid program "gbuffers_weather"
    [Shaders][SEVERE] Error compiling vertex shader: /shaders/composite.vsh
    [Shaders] Shader info log: /shaders/composite.vsh
    ERROR: 0:1: '' : version '400' is not supported
    ERROR: 0:1: '' : syntax error: #version
    ERROR: 0:123: '(' : syntax error: Array size must appear after variable name

    [Shaders] Noise texture enabled
    [Shaders] Noise texture resolution: 1024
    [Shaders][SEVERE] Error compiling fragment shader: /shaders/composite.fsh
    [Shaders] Shader info log: /shaders/composite.fsh
    ERROR: 0:1: '' : version '400' is not supported
    ERROR: 0:1: '' : syntax error: #version
    ERROR: 0:155: '(' : syntax error: Array size must appear after variable name

    [Shaders][SEVERE] Error linking program: 14
    [Shaders] Info log: /shaders/composite.vsh, /shaders/composite.fsh
    ERROR: One or more attached shaders not successfully compiled

    [Shaders] Info log: /shaders/composite.vsh, /shaders/composite.fsh
    Validation Failed: Link error:
    Program is not successfully linked.

    [Shaders][SEVERE] [Shaders] Error: Invalid program "composite"
    [Shaders][SEVERE] Error compiling vertex shader: /shaders/composite1.vsh
    [Shaders] Shader info log: /shaders/composite1.vsh
    ERROR: 0:1: '' : version '400' is not supported
    ERROR: 0:1: '' : syntax error: #version
    ERROR: 0:123: '(' : syntax error: Array size must appear after variable name

    [Shaders] Noise texture enabled
    [Shaders] Noise texture resolution: 1024
    [Shaders][SEVERE] Error compiling fragment shader: /shaders/composite1.fsh
    [Shaders] Shader info log: /shaders/composite1.fsh
    ERROR: 0:1: '' : version '400' is not supported
    ERROR: 0:1: '' : syntax error: #version
    ERROR: 0:136: '(' : syntax error: Array size must appear after variable name

    [Shaders][SEVERE] Error linking program: 14
    [Shaders] Info log: /shaders/composite1.vsh, /shaders/composite1.fsh
    ERROR: One or more attached shaders not successfully compiled

    [Shaders] Info log: /shaders/composite1.vsh, /shaders/composite1.fsh
    Validation Failed: Link error:
    Program is not successfully linked.

    [Shaders][SEVERE] [Shaders] Error: Invalid program "composite1"
    [Shaders][SEVERE] Error compiling vertex shader: /shaders/composite2.vsh
    [Shaders] Shader info log: /shaders/composite2.vsh
    ERROR: 0:1: '' : version '400' is not supported
    ERROR: 0:1: '' : syntax error: #version
    ERROR: 0:123: '(' : syntax error: Array size must appear after variable name

    [Shaders] Shadow map resolution: 4096
    [Shaders] Shadow map distance: 140.0
    [Shaders] shadowHardwareFiltering0
    [Shaders] Sun path rotation: -40.0f
    [Shaders] Noise texture enabled
    [Shaders] Noise texture resolution: 1024
    [Shaders][SEVERE] Error compiling fragment shader: /shaders/composite2.fsh
    [Shaders] Shader info log: /shaders/composite2.fsh
    ERROR: 0:1: '' : version '400' is not supported
    ERROR: 0:1: '' : syntax error: #version
    ERROR: 0:5: 'f' : syntax error: syntax error

    [Shaders][SEVERE] Error linking program: 14
    [Shaders] Info log: /shaders/composite2.vsh, /shaders/composite2.fsh
    ERROR: One or more attached shaders not successfully compiled

    [Shaders] Info log: /shaders/composite2.vsh, /shaders/composite2.fsh
    Validation Failed: Link error:
    Program is not successfully linked.

    [Shaders][SEVERE] [Shaders] Error: Invalid program "composite2"
    [Shaders][SEVERE] Error compiling vertex shader: /shaders/composite3.vsh
    [Shaders] Shader info log: /shaders/composite3.vsh
    ERROR: 0:1: '' : version '400' is not supported
    ERROR: 0:1: '' : syntax error: #version
    ERROR: 0:124: '(' : syntax error: Array size must appear after variable name

    [Shaders] gaux1 mipmap enabled for /shaders/composite3.fsh
    [Shaders][SEVERE] Error compiling fragment shader: /shaders/composite3.fsh
    [Shaders] Shader info log: /shaders/composite3.fsh
    ERROR: 0:1: '' : version '400' is not supported
    ERROR: 0:1: '' : syntax error: #version
    ERROR: 0:424: '(' : syntax error: Array size must appear after variable name

    [Shaders][SEVERE] Error linking program: 14
    [Shaders] Info log: /shaders/composite3.vsh, /shaders/composite3.fsh
    ERROR: One or more attached shaders not successfully compiled

    [Shaders] Info log: /shaders/composite3.vsh, /shaders/composite3.fsh
    Validation Failed: Link error:
    Program is not successfully linked.

    [Shaders][SEVERE] [Shaders] Error: Invalid program "composite3"
    [Shaders][SEVERE] Error compiling vertex shader: /shaders/composite4.vsh
    [Shaders] Shader info log: /shaders/composite4.vsh
    ERROR: 0:1: '' : version '400' is not supported
    ERROR: 0:1: '' : syntax error: #version
    ERROR: 0:131: '(' : syntax error: Array size must appear after variable name

    [Shaders][SEVERE] Error compiling fragment shader: /shaders/composite4.fsh
    [Shaders] Shader info log: /shaders/composite4.fsh
    ERROR: 0:1: '' : version '400' is not supported
    ERROR: 0:1: '' : syntax error: #version

    [Shaders][SEVERE] Error linking program: 14
    [Shaders] Info log: /shaders/composite4.vsh, /shaders/composite4.fsh
    ERROR: One or more attached shaders not successfully compiled

    [Shaders] Info log: /shaders/composite4.vsh, /shaders/composite4.fsh
    Validation Failed: Link error:
    Program is not successfully linked.

    [Shaders][SEVERE] [Shaders] Error: Invalid program "composite4"
    [Shaders][SEVERE] Error compiling vertex shader: /shaders/composite5.vsh
    [Shaders] Shader info log: /shaders/composite5.vsh
    ERROR: 0:1: '' : version '400' is not supported
    ERROR: 0:1: '' : syntax error: #version
    ERROR: 0:131: '(' : syntax error: Array size must appear after variable name

    [Shaders][SEVERE] Error compiling fragment shader: /shaders/composite5.fsh
    [Shaders] Shader info log: /shaders/composite5.fsh
    ERROR: 0:1: '' : version '400' is not supported
    ERROR: 0:1: '' : syntax error: #version

    [Shaders][SEVERE] Error linking program: 14
    [Shaders] Info log: /shaders/composite5.vsh, /shaders/composite5.fsh
    ERROR: One or more attached shaders not successfully compiled

    [Shaders] Info log: /shaders/composite5.vsh, /shaders/composite5.fsh
    Validation Failed: Link error:
    Program is not successfully linked.

    [Shaders][SEVERE] [Shaders] Error: Invalid program "composite5"
    [Shaders][SEVERE] Error compiling vertex shader: /shaders/final.vsh
    [Shaders] Shader info log: /shaders/final.vsh
    ERROR: 0:1: '' : version '400' is not supported
    ERROR: 0:1: '' : syntax error: #version
    ERROR: 0:131: '(' : syntax error: Array size must appear after variable name

    [Shaders][SEVERE] Error compiling fragment shader: /shaders/final.fsh
    [Shaders] Shader info log: /shaders/final.fsh
    ERROR: 0:1: '' : version '400' is not supported
    ERROR: 0:1: '' : syntax error: #version

    [Shaders][SEVERE] Error linking program: 14
    [Shaders] Info log: /shaders/final.vsh, /shaders/final.fsh
    ERROR: One or more attached shaders not successfully compiled

    [Shaders] Info log: /shaders/final.vsh, /shaders/final.fsh
    Validation Failed: Link error:
    Program is not successfully linked.

    [Shaders][SEVERE] [Shaders] Error: Invalid program "final"
    [Shaders][SEVERE] Error compiling vertex shader: /shaders/shadow.vsh
    [Shaders] Shader info log: /shaders/shadow.vsh
    ERROR: 0:1: '' : version '400' is not supported
    ERROR: 0:1: '' : syntax error: #version
    ERROR: 0:105: 'switch' : Reserved word.
    ERROR: 0:105: 'switch' : syntax error: syntax error

    [Shaders][SEVERE] Error compiling fragment shader: /shaders/shadow.fsh
    [Shaders] Shader info log: /shaders/shadow.fsh
    ERROR: 0:1: '' : version '400' is not supported
    ERROR: 0:1: '' : syntax error: #version

    [Shaders][SEVERE] Error linking program: 14
    [Shaders] Info log: /shaders/shadow.vsh, /shaders/shadow.fsh
    ERROR: One or more attached shaders not successfully compiled

    [Shaders] Info log: /shaders/shadow.vsh, /shaders/shadow.fsh
    Validation Failed: Link error:
    Program is not successfully linked.

    [Shaders][SEVERE] [Shaders] Error: Invalid program "shadow"
    [Shaders] usedColorBuffers: 8
    [Shaders] usedDepthBuffers: 2
    [Shaders] usedShadowColorBuffers: 0
    [Shaders] usedShadowDepthBuffers: 2
    [Shaders] usedColorAttachs: 8
    [Shaders] usedDrawBuffers: 1
    [Shaders] Framebuffer created.
    [Shaders] Shadow framebuffer created.
    [Shaders] Reset world renderers
    [Shaders] Reset model renderers

    Posted in: Minecraft Mods
  • 0

    posted a message on [1.14] Chocapic13's Shaders

    All versions are completely broken on my Mac. I've attached exactly what comes up when I try to load the Extreme version. Here are my specs:


    * i7-6700k

    * AMD M395X

    * Minecraft 1.10.2 w/ Optifine

    * macOS 10.12 "Sierra"

    Posted in: Minecraft Mods
  • 0

    posted a message on [1.14] Chocapic13's Shaders

    I don't know how to customize Chocapic13's Shaderpack, i know how to disable some stuffs but that's all i know, im not like SonicEther, DeDelner, i need help, even you say to me (learn GLSL then) i don't know. :'(



    No-one here can help you. If you want to learn, you need to take some initiative and do it yourself. Here are some GLSL tutorials for you to start with:

    http://www.lighthouse3d.com/tutorials/glsl-tutorial/

    Or, if you prefer video tutorials instead:



    If you've never done any programming before, you might want to take a look into learning the basics of a language before jumping into 3D graphics and shaders, as both can be a rather complex concept. Some common beginner programming languages include Python, Java, Swift, and C (and variants). Take a look into those, or if you need some help choosing, there are some websites and tools to help you choose which programming language is for you. This one is the simplest I've found.

    http://www.bestprogramminglanguagefor.me

    With those tools in mind (and a willingness to use Google), you're on your way to becoming a GLSL master.

    Posted in: Minecraft Mods
  • 0

    posted a message on [1.14] Chocapic13's Shaders

    sensi277 what is this "Light" version of yours? A rename of the low version?



    I don't recall having a "Light" version of yShaders. I might have in some of the really old versions, but as of the last released version (2.3.3), the order goes from low quality to high quality like this: Low, Medium, High, Ultra.


    Edit: Just took a look, it looks like only version 1.1 and older of yShaders has a "Light" version. You might want to try to find a newer copy.

    Posted in: Minecraft Mods
  • 0

    posted a message on [1.14] Chocapic13's Shaders
    Quote from Triliton»

    some shaders needs to be unzipped. Thats because we sometimes use different programs to code the shaders


    If that was the case, he'd see the shader pack in the menu, but it would do nothing when he clicked on it. He's saying that it doesn't show up at all.
    Posted in: Minecraft Mods
  • To post a comment, please or register a new account.