• 0

    posted a message on Server not working since 1.14.4

    Bummer, I don't have an earlier backup. Sounds like I'm out of luck?


    Edit: I did have an earlier level.dat backed up but it has the same issue (client just sees background and no blocks load before getting disconnected)

    Posted in: Server Support and Administration
  • 0

    posted a message on Server not working since 1.14.4
    Quote from Tails1»

    Try allocating more RAM.



    Tried setting it to 8gb (total on my little linux box) but still crashes with that old world. It's weird because when I connect as a client I can look around for a few seconds but only see the background/skybox (no blocks load). Then I get kicked (internal server error). If I try to keep reconnecting I get:


    io.netty.channel.AbstractChannel$AnnotatedConnectException: Connection refused: no further information


    Not sure if that is meaningful. Is my old world a lost cause?


    I appreciate your help.

    Posted in: Server Support and Administration
  • 0

    posted a message on Server not working since 1.14.4
    Quote from Tails1»

    How old is the world then? What's the last version it was on before upgrading to 1.14?



    I believe it would have been 1.14.3, but I could be wrong (it's been a while since I played but I usually logged in frequently to make sure it kept up to date with the client). Is there a way I can find out what the world version was? Edit: and more importantly, can I migrate it? I had a lot of stuff built with my brother and nephew and friends.

    Posted in: Server Support and Administration
  • 0

    posted a message on Server not working since 1.14.4
    Quote from Tails1»

    Does it happen on one world or are others affected?


    Looks like a fresh world works fine. Is the a migration needed for my old world?

    Posted in: Server Support and Administration
  • 0

    posted a message on Server not working since 1.14.4

    Ever since switching to MC 1.14.4, my 18.04 ubuntu server no longer works. I am able to connect as a client in fact, but it's like the world doesn't load and after a few seconds I get kicked.


    I have had issues with Java on Ubuntu 18.04 and wonder if it might be related? I tried the following versions thus far:


    • apt install default-jre
    • apt install openjdk-8-jre-headless

    Here is the most recent crash/dump on Java 8 (note the server has plenty of memory free so I suspect the mentions below are a leak or something, and specifically related to java version):


    ---- Minecraft Crash Report ----
    // Don't do that.
    Time: 10/20/19 11:13 AM
    Description: Exception in server tick loop
    java.util.concurrent.CompletionException: java.lang.OutOfMemoryError: Java heap space
     at java.util.concurrent.CompletableFuture.encodeThrowable(CompletableFuture.java:273)
     at java.util.concurrent.CompletableFuture.completeThrowable(CompletableFuture.java:280)
     at java.util.concurrent.CompletableFuture$AsyncSupply.run(CompletableFuture.java:1592)
     at agq.h(SourceFile:144)
     at agq.q(SourceFile:118)
     at vi$a.q(SourceFile:550)
     at agq.c(SourceFile:127)
     at vi.a(SourceFile:135)
     at bhr.a(SourceFile:194)
     at vk.f(SourceFile:869)
     at vk.c(SourceFile:852)
     at xv.a(SourceFile:183)
     at we.c(SourceFile:111)
     at we.b(SourceFile:63)
     at jc.a(SourceFile:230)
     at wb.c(SourceFile:171)
     at net.minecraft.server.MinecraftServer.b(SourceFile:847)
     at uk.b(SourceFile:343)
     at net.minecraft.server.MinecraftServer.a(SourceFile:774)
     at net.minecraft.server.MinecraftServer.run(SourceFile:642)
     at java.lang.Thread.run(Thread.java:748)
    Caused by: java.lang.OutOfMemoryError: Java heap space
     at il.a(SourceFile:64)
     at id.a(SourceFile:438)
     at id.a(SourceFile:81)
     at id.a(SourceFile:438)
     at id.a(SourceFile:81)
     at id.a(SourceFile:438)
     at id.a(SourceFile:81)
     at id.a(SourceFile:438)
     at id.a(SourceFile:81)
     at io.a(SourceFile:113)
     at io.a(SourceFile:78)
     at io.a(SourceFile:74)
     at byj.e(SourceFile:53)
     at uw.g(SourceFile:816)
     at uw.j(SourceFile:506)
     at uw$Lambda$2109/612472159.get(Unknown Source)
     at java.util.concurrent.CompletableFuture$AsyncSupply.run(CompletableFuture.java:1590)
     at agq.h(SourceFile:144)
     at agq.q(SourceFile:118)
     at vi$a.q(SourceFile:550)
     at agq.c(SourceFile:127)
     at vi.a(SourceFile:135)
     at bhr.a(SourceFile:194)
     at vk.f(SourceFile:869)
     at vk.c(SourceFile:852)
     at xv.a(SourceFile:183)
     at we.c(SourceFile:111)
     at we.b(SourceFile:63)
     at jc.a(SourceFile:230)
     at wb.c(SourceFile:171)
     at net.minecraft.server.MinecraftServer.b(SourceFile:847)
     at uk.b(SourceFile:343)
    
    A detailed walkthrough of the error, its code path and all known details is as follows:
    ---------------------------------------------------------------------------------------
    -- System Details --
    Details:
     Minecraft Version: 1.14.4
     Minecraft Version ID: 1.14.4
     Operating System: Linux (amd64) version 4.15.0-65-generic
     Java Version: 1.8.0_222, Private Build
     Java VM Version: OpenJDK 64-Bit Server VM (mixed mode), Private Build
     Memory: 1991057040 bytes (1898 MB) / 2893021184 bytes (2759 MB) up to 2893021184 bytes (2759 MB)
     CPUs: 4
     JVM Flags: 1 total; -Xmx3G
     Player Count: 0 / 20; []
     Data Packs: vanilla
     Is Modded: Unknown (can't tell)
     Type: Dedicated Server (map_server.txt)


    Posted in: Server Support and Administration
  • 0

    posted a message on Server connectivity issue on Ubuntu 18.04

    Solved! Feel free to follow the reddit thread linked above to see the thread of troubleshooting that lead to the solution, but in short you must use java-8 (java-11 from 18.04 master is the issue, and even running both will cause problems).

    Posted in: Server Support and Administration
  • 0

    posted a message on Server connectivity issue on Ubuntu 18.04

    Do bumps work? I hope so, cause it seems no1 wants to take a crack at this :(


    Some updates since (reddit thread is more active)


    - Tried Java 8

    - tried to update certificates again


    No luck :(

    Posted in: Server Support and Administration
  • 0

    posted a message on Server connectivity issue on Ubuntu 18.04

    I had success setting up a minecraft server on ubuntu 16.04 for the first time a month or so ago - it ran fine the whole time - a learning experience in both minecraft and ubuntu. Since ubuntu 18.04 was recently released, I decided to format and start over - but for some reason I can't connect to minecraft when "online-mode=true" (but can connect fine without authentication by setting online-mode=false). If online-mode=true, it produces a console messages like the following when I try and connect (I replaced my username for privacy, but I do have a legit account that worked fine previously, I can also connect to other authenticated servers fine):

    [21:24:29] [Server thread/INFO]: Done (6.275s)! For help, type "help" or "?"
    [21:24:40] [User Authenticator #1/INFO]: Disconnecting [email protected][id=,name=myusername,properties={},legacy=false] (/192.168.2.12:62497): Authentication servers are down. Please try again later, sorry!
    [21:24:40] [User Authenticator #1/ERROR]: Couldn't verify username because servers are unavailable
    [21:24:40] [Server thread/INFO]: [email protected][id=,name=myusername,properties={},legacy=false] (/192.168.2.12:62497) lost connection: Authentication servers are down. Please try again later, sorry!


    I have a strong suspicion this isn't an issue with Minecraft or Ubuntu 18.04, just something I missed/didn't do when setting up - most likely specific to the network config (perhaps netplan or iptables related - or the server.properties?).


    Maybe there's just a specific ufw rule/port I need to open specific to Mojang's authentication servers? I have 25565 TCP and UDP open already on the server.


    Or perhaps my version of Java is wrong?


    I have what looks to be proper routing of ports on my router (same as I did on 16.04 with the same network IP). Testing other services I installed such as apache and SSH I can hit the server fine (over the local network or externally in a web browser, for example) so this is an issue specific to Minecraft.


    Any ideas what's going on here / what I might be missing? Any help is greatly appreciated. Thanks in advance!!


    ---


    Reddit thread: I also posted this near identical thread on the minecraft sub-reddit but didn't get a solution, just wanted to be transparent.


    -------


    Solved!

    Feel free to follow the reddit thread linked above to see the thread of troubleshooting that lead to the solution, but in short you must use java-8 (java-11 from 18.04 master is the issue, and even running both will cause problems).

    Posted in: Server Support and Administration
  • To post a comment, please or register a new account.