• 0

    posted a message on Gradlew build failed

    Did you look in the ReadMe of the Forge MDK, you should be using "gradlew genEclipseRuns" or "gradlew genIntellijRuns" to setup the workspace files.

    Posted in: Modification Development
  • 0

    posted a message on can i update a mod from 1.12.2 to 1.16.3 if the original creator hasn't

    For you to update a mod that is not yours you would need the source code from the author of the mod, you would then have to change all the outdated code that doesn't work with 1.16.3 and because of the big gap between 1.12.2 and 1.16.3 it's probably all of the code so it's most likely your making the mod from scratch.

    Posted in: Modification Development
  • 0

    posted a message on Java Version

    Thanks for replying I looked into it bit more and I think I figure out a little on how Eclipse and the Forge build use the Java JRE and JDK. I ended up with having to use both Java 8 and 11 since my Eclipse wouldn't start without Java 11. I could have delete Java 8 and just had 11 but I kept it because Java 8 is Minecraft's default and I believe if I coded my mods in Java 11 it would require people to also get it if I used any features that are in 11 and not in 8. Anyways it all seems to work normal since I can use Java 8 in my Eclipse workspace as I used it to before.


    Note that I'm not really sure if my thinking is right since I didn't see a mod that was on a higher Java version that had problems with a older version that I could have tested.

    Posted in: Modification Development
  • 0

    posted a message on Java Version

    I was wondering if I can use Java 11 or higher JRE and JDK for Minecraft modding, I have always used Java 8 but just recently I updated my Eclipse IDE and it now requires Java 11 or higher to be able to use. So can I use Java 11 or higher, or should I just have both of them?

    Posted in: Modification Development
  • 0

    posted a message on Should I Remove IHasModel

    Thanks for the reply and information I'll make sure to stop using it.

    Posted in: Modification Development
  • 0

    posted a message on Texture loading error

    You are missing the s in textures.items

    Posted in: Modification Development
  • 0

    posted a message on Should I Remove IHasModel

    I was watching some Minecraft modding tutorials for 1.12.2 and I came across one that showed how to remove IHasModel. So I was wondering if I should remove IHasModel and what is the difference on having it and not having it. I'll also notice some Modders don't use it so I'm thinking of changing.

    Posted in: Modification Development
  • 0

    posted a message on How do you make modded entities hold items? [1.12.2]

    Have you looked in the Minecraft's EntityWitherSkeleton class and AbstractSkeleton class, both these classes have a method called setEquipmentBasedOnDifficulty, after playing around with it I was able to change what the Skeletons were holding, this might be what your looking for i'm not sure.

    Posted in: Modification Development
  • 1

    posted a message on What Do You Have To Have In Order To Setup Forge With Eclipse For Minecraft 1.12.2 - 1.16.1?

    The forge mdk folder, should be in another folder that contains all your mod projects. Like my mod projects are all in a folder called Mod Projects.


    You then run both the commands gradlew genEclipseRuns and gradlew eclipse for the forge mdk folder.


    Then open Eclipse and for workspace you select the folder that contains the forge mdk folder.


    Then in Eclipse right click and select import.


    After, you go into General and select Existing Project into Workspace.



    Then click Browse and select the forge mdk folder and click Finish.


    Then it should apper in your Package Explorer

    Posted in: Modification Development
  • 0

    posted a message on What Do You Have To Have In Order To Setup Forge With Eclipse For Minecraft 1.12.2 - 1.16.1?

    You should have a folder to store all your eclipse projects, that is your workspace folder. You then have a folder that is the name of your mod, in which then you put everything from the forge mdk folder into your mod folder, the mod folder should be in the workspace folder. Then run the commands gradlew genEclipseRuns and gradlew eclipse for your mod folder. Then open Eclipse and choose the workspace folder that contains your mod folder. Then in Eclipse do import Existing Project into Workspace and choose your mod folder. If it doesn't import you can also try only running the command gradlew genEclipseRuns and not gradlew eclipse, then in Eclipse import as Existing Gradle Project. If it is still not working, you should just watch a YouTube video on how to setup mod project.


    For minecraft versions 1.12.2 - 1.16.1, json files are now used for crafting recipes.


    Also a lot of things change for newer versions of minecraft modding, it's not always the same or similar. There is a big difference between 1.11.2 and 1.12.2.


    For last, the ReadMe does show all the minimum steps that are needed to setup your mod project. Also delete any example or test files from when you copy the forge mdk folder files.

    Posted in: Modification Development
  • 0

    posted a message on What Do You Have To Have In Order To Setup Forge With Eclipse For Minecraft 1.12.2 - 1.16.1?

    Read the readme in the forge folder, it's no longer gradlew setupDecompWorkspace, it's now or for at least 1.12.2 gradlew genEclipseRuns or gradlew genIntellijRuns.

    Posted in: Modification Development
  • 0

    posted a message on Modding Help Requested

    Did you name it in your lang, itemGroup.scrTab=Name, for under 1.13 or "itemGroup.scrTab": "Name", for 1.13 and up.

    Posted in: Modification Development
  • 0

    posted a message on [Solved] How To Make More Then One Fluid

    I figured out how to do it. If anyone would like to know, I made a Youtube tutorial video on my channel.

    Posted in: Modification Development
  • 0

    posted a message on oracle

    Eclipse IDE for Java Developers. Yes

    Posted in: Modification Development
  • 0

    posted a message on Could not run build action using Gradle Distribution

    Have you read the Readme in the forge folder. Also to change the view click on the 3 dots next to Package Explorer and in Package Presentation select Hierarchical.

    Posted in: Modification Development
  • To post a comment, please or register a new account.