• 0

    posted a message on Terrible FPS with a decent laptop, I am at at my wit's end...

    Well, I allocated 6 and then 8 gigs of Ram, same thing happens roughly 10 minutes into the game. I even got rid of that dreaded "SEUS Shaders" which somehow fixed the FPS issue. I can now get 20-25 FPS. I also enabled SLI for minecraft as shown on this guide here - https://www.reddit.com/r/Minecraft/comments/c6q7ov/nvidia_sli_with_optifine_and_seus_shader_pack/

    According to the SLI indicator, my GPUs aren't even utilized 50% for most of the time.


    Another problem I notice is that, even though I have 12 GB of Ram, and the javaw.exe process takes 4-5 GB at most, the task manager shows my Physical Memory as 85-90% utilized once Minecraft is launched. Before that the utilization was 15%. Adding all the processes together doesn't even reach 8GB.

    I'd appreciate it if you found something from the log - https://pastebin.com/wzRQSak9

    This is just getting more ridiculous than I anticipated...


    Also, I realized that Geforce Experience couldn't automatically install the latest drivers, so I did it myself which had no effect on Minecraft unfortunately. From what I checked, my GPU (probably even a single of them) should be able to run Minecraft with some shaderpack at 50 or more FPS. I'd be happy if it can stay at 25 without some ludicrous "error" message to be honest.

    Posted in: Java Edition Support
  • 0

    posted a message on Terrible FPS with a decent laptop, I am at at my wit's end...

    Thank you for the suggestion. I do indeed have the latest drivers. Could it also be an issue with SLI? Maybe I should try disabling it first to see if it works, otherwise, I'll go to the previous version to see how it works. I got mixed responses from googling whether Minecraft does benefit from SLI or not. In the meantime, was I right in assuming that my hardware is more than capable of handling this configuration?

    Posted in: Java Edition Support
  • 0

    posted a message on Terrible FPS with a decent laptop, I am at at my wit's end...

    Hello everyone, I have started playing minecraft a few weeks ago. While unmodded Minecraft works fine, I have decided to experiment with a few mods. I have also took my time and tried the recommendations of this guide here. Before I go further, I should talk about my specs maybe.I have an i7 4900MQ CPU, 2X 680M SLI GPUs and 12 GB of RAM. I can play most games of 2013-2016 era at high settings. And according to the guide I mentioned earlier, I should have no problem whatsoever running a modded game since I have way better specs than what was shown there (A way better CPU, a slightly better GPU but with SLI configuration. So, potentially over twice the graphic performance)Right now, this is the problem I am having. Once the game starts, the FPS is shown to be around 15, but from what I remember playing games like Skyrim, FPS of 15 was unbearable and controls were unresponsive, so you cannot do anything action heavy effectively. But here for some reason, I could fight monsters and actually enjoy the game. Until... a few minutes in and the game freezes for roughly 3 minutes straight. After it unfreezes, it lags every 5 seconds or so momentarily making doing anything very annoying. 10 more minutes like this and crashes with an error log which I will post of course.


    I have 1 shader pack and 1 512x resourse pack, called Mainly Photo Realism 1.15. The game works fine with just the resource pack but it looks infinitely better with the shader pack and given that I have a more than strong enough hardware, I see no reason why I shouldn't try it.


    I have the latest version of Minecraft by the way (1.16.3).The mods I have are:


    cloth-config-forge-4.1.0.jar


    CreativeCore-1.16.2.jar


    ImmersiveEngineering-1.16.3-4.0.1-121.jar


    light-overlay-5.5.3.jar


    MixinBootstrap-1.0.3.jar


    preview_OptiFine_1.16.3_HD_U_G3_pre1.jar (I disabled "Animated terrain" feature after reading that it may cause enormous performance drop while providing little-to-no visual benefit)


    The shader pack I have is SEUS-Renewed-1.0.1


    Apart from these changes, I used jdk-8.0.265.01-hotspot from https://adoptopenjdk.net/ since it was supposed to improve performance. But the same problem persisted when I switched back to the regular 64-bit Java.


    The only JVM argument I have currently is -Xmx6G


    Before I launch the game, my RAM usage is at 10-15%. But once the game is launched, my RAM usage jumps to 85-90% even when javaw.exe is shown to be using 2-3 GBs, which doesn't add up as long as basic math is concerned. When I add all other processes together, It shouldn't even crack 50% of RAM usage let alone 90%.


    Since I am relatively new to Minecraft configuration, I am totally clueless as to how I should proceed now. What could possibly cause this problem and how should I go about correcting it?


    I even used a program called "Vista Services Optimizer" which also works for Win7 that disabled windows background junk to free up resources when you set it to gaming mode.


    Any suggestions are highly appreciated, here is the error log that is created after the game crashes 10-15 minutes in. My expectations aren't very high by the way. I am more than perfectly happy if I can get 20-25 FPS which is still underwhelming for my laptop, but at this point I'd take it.


    Here is the pastebin link to my crash log - Error log


    Thanks to everyone in advance.


    In case you need more information, please let me know.

    Posted in: Java Edition Support
  • To post a comment, please or register a new account.