• 0

    posted a message on [1.4.7]Wireless Redstone v1.6.1
    Quote from animat0rjs

    java.lang.IllegalArgumentException: Slot 127 is already occupied by [email protected] when adding [email protected]


    Really old property file. Huh? D:
    Posted in: Minecraft Mods
  • 0

    posted a message on [1.4.7]Wireless Redstone v1.6.1
    Quote from HaydenAlmeida

    I've tried to change the Wireless IDs but it does not work!
    I have installed: RedPower 2 and Forge (I Think Mod Loader too)
    So i think i was needed only copy and paste the ZIP to "mod" folder and Play.
    But the game is crashing, i tryied to change the IDs so many times and does not work yet.



    I am not aware of any block ID conflicts with RP2.
    But you could cross reference the configs just in case.
    Stick to something between 160-250 preferably.

    May I see your entire log please?
    Forge and WR log. In spoiler tags. ;)
    Posted in: Minecraft Mods
  • 0

    posted a message on [1.4.7]Wireless Redstone v1.6.1
    Quote from HaydenAlmeida

    Same Error :/

    -------
    How do i Install the Mod:

    1º: COpy the Mod Rar Archieve into "MODS" Folder.

    OR

    2º: "Instal" the files inside Rar of the mod, copying all of then for the minecraft.jar?

    Or BOTH?


    Obviously, you need to change the IDs. I've already told you this.

    And there is no rar. Only zip files. If you have rar files you are doing it wrong.
    Manual install instructions are in the OP. If they are too confusing; use the automatic installer.
    Posted in: Minecraft Mods
  • 0

    posted a message on [1.4.7]Wireless Redstone v1.6.1
    Quote from Mcgver

    I have the lastest 1.4.7


    Yerp. Current version of Wireless Redstone is for 1.4.6.
    There will probably be an update sometime during this weekend.
    Posted in: Minecraft Mods
  • 0

    posted a message on [1.4.7]Wireless Redstone v1.6.1
    Quote from Mcgver

    Everytime I download this and try to run it. The program will come up with the different versions but it will not let me click on any of the versions. When I click install all I get is a bonk sound.


    It's because your current version of minecraft is not compatible with any on the list.
    Posted in: Minecraft Mods
  • 0

    posted a message on [1.4.7]Wireless Redstone v1.6.1
    Quote from HaydenAlmeida


    How to download This? It only a text, not a download, not for me :)


    Right click, save link as
    Quote from canx35

    No it is the himself error


    The what error?
    Posted in: Minecraft Mods
  • 0

    posted a message on [1.4.7]Wireless Redstone v1.6.1
    Quote from HaydenAlmeida

    Man , i think u dont understand. I Install the MOd when i Lauch the Game, it Crashes!
    SO i dont have ANY properties file on my .minecraft


    Oh, sorry. Of course not.
    Put this file in your .minecraft folder:
    http://minecraft.ali4z.com/downloads/wirelessRedstone.properties
    Posted in: Minecraft Mods
  • 0

    posted a message on [1.4.7]Wireless Redstone v1.6.1
    Quote from HaydenAlmeida

    I Dont find the Properties File! Help me


    %appdata%/.minecraft
    Posted in: Minecraft Mods
  • 0

    posted a message on [1.4.7]Wireless Redstone v1.6.1
    Quote from HaydenAlmeida

    Same Error!


    Same answer.
    Posted in: Minecraft Mods
  • 0

    posted a message on [1.4.7]Wireless Redstone v1.6.1
    Quote from canx35

    in my mod pack for my came the error :


    java.lang.IllegalArgumentException: Duplicate id: Wireless Receiver
    ...


    You need to change the Wireless Receiver block ID, because it is conflicting with another block.
    You can do this with the properties file. :)
    Quote from RunThroughTime

    1.4.7 just got released. Updating the mod?


    Of course. Probably sometime during the weekend.
    Posted in: Minecraft Mods
  • 0

    posted a message on [Unsolved][Forge]Making mod for SMP - going further
    Quote from -Reaper-

    I tried using your code, but it doesn't work for me. I get error on @SidedPacketHandler. "The value for annotation attribute NetworkMod.clientPacketHandlerSpec must be some @cpw.mods.fml.common.network.NetworkMod.SidedPacketHandler annotation"


    Should work perfectly. It is pretty much identical to the one I use, except with other channels, obviously.
    Make sure to implement the handler classes. They should be using the IPacketHandler interface, or a child of it.
    Posted in: Modification Development
  • 1

    posted a message on [Unsolved][Forge]Making mod for SMP - going further
    I would recommend having separate server and client packet handlers.

    Like so...
    @NetworkMod(
        clientSideRequired = true,
        serverSideRequired = false,
        clientPacketHandlerSpec = @SidedPacketHandler(
            channels = { "CaveGen" },
            packetHandler = ClientPacketHandler.class
        ),
        serverPacketHandlerSpec = @SidedPacketHandler(
            channels = { "CaveGen" },
            packetHandler = ServerPacketHandler.class
        )
    )


    I'm not sure why that would fix anything, what you've got looks ok from what I skimmed over it, but you might as well separate it right away. Common packet handling makes little sense.
    Posted in: Modification Development
  • 1

    posted a message on [Unsolved][Forge]Making mod for SMP - going further
    Quote from -Reaper-

    Thank you! My main concern is, that the mod specifies it loads info from saves directory, which will be impossible on the client side, since the file will be stored at server side.


    By net-code I mean the communication. Passing and handling of messages/packets/calls/telegrams/whatever the cool kids call it these days.
    You can do server-only stuff, with proxies and/or with the good old isRemote.

    Here's some info on proxies: http://www.minecraft...et/wiki/Proxies
    Basically when you call a proxy method, Forge sorts automatically which one to use depending on side.

    So you can, for example, have the common proxy fetch the file content. Then have the client proxy override this method to return nothing, or make a request to the server if needed. Not sure why the client would need that info though. But if it does; then you indeed do need custom packets and packet handling.

    EDIT:
    Here is a method I made for finding out which side you're on. If you need it:
    private String getSide(boolean isRemote) {
       if ( FMLCommonHandler.instance().getSide() == Side.CLIENT ) {
          if ( isRemote )
             return "CLIENT";
          else
             return "INTEGRATED_SERVER";
       }
    
       if (FMLCommonHandler.instance().getSide() == Side.SERVER )
          return "SERVER";
    
       return "UNKNOWN";
    }

    Where isRemote is the World.isRemote.
    Posted in: Modification Development
  • 0

    posted a message on [1.4.7]Wireless Redstone v1.6.1
    Quote from bruceG

    Ok, well, I have to stand somewhat corrected....

    Sorry, I THOUGHT I had the story straight before I posted! :-)

    They DO also have "More Pistons" mod installed...
    And the issue MAY stem from using wireless redstone with the extra pistons.


    My daughter says that ( not often) the second PC comes back and says " can't connect". or timed out..

    But most often, when the second PC connects, in the area there is wireless redstone placed, there is some huge "world glitch"...(?)
    Usually looks like a large radiator made from stone ( like a home heating radiator..grill sort of thing)
    But that ONLY appears on the second PC, not the host PC.
    On the host PC the world looks normal.

    hardwired through router, no wifi.
    Host PC are quad-core proc. ( 3.4ghz) with 12 gig Ram.. good graphics etc.. no lag that is noticeable.
    Second PC is dual core 2.7ghz with 4gig ram.
    Both running win 7 64 bit.

    Rebooting makes no difference.

    Again, these issues only happen if wireless redstone has actually been used in the world.
    No problems otherwise.

    As far as the log... well, I have not looked at it... and not sure I'd know WHAT I was looking at

    I think I need to test this a bit more now, create the issue, and get a better handle on what's happening myself before I waste any more of your time..



    Thanks


    Wonderful. The more info the better. :D
    Don't worry about wasting my time. Sorting out user issues always has highest priority; if there's no time for that, there is no time for anything anyways. :P

    This issue sounds incredibly odd though.
    I'll have a look at it myself when I get home back from work.

    In the meantime; if you could check if it also happens if you join up with a different computer. For example open up a new minecraft client on the same computer you are hosting from, using a different account (your daughter's, for example. Or an unauthed if that works)
    If that works as expected; then the issue might lie with the second PC. In which case; reinstalling minecraft might sort it out.
    Posted in: Minecraft Mods
  • 0

    posted a message on [1.4.7]Wireless Redstone v1.6.1
    Quote from bruceG

    Hi,

    A question I have I THINK directly relates to the use of wireless redstone...

    When we open a world to LAN, play a while, everything is fine on both PCs.
    But, once the game is shut down, and we try to restart the game with the same world.. open it to
    LAN again, the second PC can no longer connect.

    If all the wireless redstone is removed before stopping the game, SOMETIMES the next time the second PC can connect via LAN.

    With any world that wireless redstone is not used at all, the second PC can connect all the time, with no issue.

    Obviously, I'm new here, so if there is info I haven't given you that you need.... just tell me! :-)

    Thanks for the mod !
    I can't go back to running redstone dust everywhere. :-)


    WR v1.6.1

    The version of forge that was specified in the instal instructions on page 1

    The only other mod installed is Too many items.

    Thank you.


    Hmm, doesn't sound very likely.

    What do you mean by it can't connect exactly? Does it not find it in the list? Does it ping out?
    Do you get any error messages?
    Anything in the log files?
    Is it over the WiFi? If so; does it happen when you link em up with a cable?
    Does the serving computer have a decent amount of memory? Does it lag at all? Does rebooting the computer make any difference? Etc.

    Thanks
    Posted in: Minecraft Mods
  • To post a comment, please or register a new account.