• 0

    posted a message on java.lang.NullPointerException: group -- Any help?

    I have had this problem too for a couple months on one of my computers. I upgraded the other to Windows 10, and now that has problems.

    I do not run any antivirus at the moment. Please help.


    UPDATE:

    Works fine on 1.8.9, but it seems like the 1.9 update broke it. I have already done a reinstall of Minecraft and Java. Will be updating my drivers.


    ANOTHER UPDATE:
    Did a crap ton of restarts and reinstalled my VPN. That worked.

    Posted in: Java Edition Support
  • 0

    posted a message on Server showing as offline on multiple voting sites

    Update: I found out Freenom shut down my secondary domain, so I had to fix that first. The second voting site now works 24/7, but I still have issues with the first and last ones. After browsing MCProhosting's Knowledgebase, I found that it is a monthly payment, not one-time. I will be researching a way to connect to my server using only one domain, though is there a way to connect to a server with a port other than 25565, without using an SRV record? Thanks in advance.

    Posted in: Server Support and Administration
  • 0

    posted a message on Server showing as offline on multiple voting sites
    Quote from ExedoYT»

    This may be your problem. It's been a while since I've used SRV records but IIRC not all server lists support SRV records. I know for a fact PMC supports them however I'm not sure about the other server lists however but that may be why it's not working as while. I'd reccomend buying a dedicated IP which (according to their knowledgebase) is a 1 time payment of 3 dollars.

    Thanks man.Though I find it weird because it worked for a while and suddenly stopped, I appreciate your help.
    Posted in: Server Support and Administration
  • 1

    posted a message on Can someone Help me do this?
    Quote from joembaza»

    I have iconomy and crates plus and I want crate to give you money how?


    We speak English here. XD
    Anyways, CratesPlus does not support giving money. I recommending using CrateReloaded, but make sure you install Vault first.
    Posted in: Server Support and Administration
  • 1

    posted a message on Can someone Help me do this?
    Quote from joembaza»

    thanks but I think world guard claim the spawn and what under it?


    It only claims the between the two corners, and that includes the height. It does not protect anywhere above or below where you click.

    _____ _____
    L____ PPPP
    _____ --> PPPP
    ____R PPPP
    _____ _____

    L = The block you left click
    R = The block you right click
    _ = Unprotected area
    P = Protected area
    Posted in: Server Support and Administration
  • 0

    posted a message on HELP WITH BUKKIT PERMISSIONS!!
    Quote from R2bEEaton»

    could you help me with it? pls do not send me to a video.. i would like someone to help personnally


    Most of the time, you won't get someone to walk you through step by step how to setup permissions. You need to take time yourself and watch some videos on how to do it first.

    bPermissions:


    Essentials GroupManager:


    Here's one on PermissionsEx. This one's a bit harder than the rest.
    Posted in: Server Support and Administration
  • 1

    posted a message on Can someone Help me do this?

    You need WorldEdit installed along WorldGuard. To turn pvp off, you must do this:

    Right click one corner of the spawn with a wooden axe

    Left click the other with a wooden axe

    Type "/rg define spawn". All the blocks between the two corners will be selected.

    Type "/rg flag spawn pvp deny" to disable pvp.

    Deop yourself, because operators bypass WorldGuard regions.


    If you're stuck, here's a pretty basic tutorial on how to do it.

    Posted in: Server Support and Administration
  • 0

    posted a message on People see me as in /v when I'm not

    There's a config option in Essentials which automatically vanishes OPs. Instead of typing /v every time, find and change that option.

    Posted in: Server Support and Administration
  • 0

    posted a message on Server showing as offline on multiple voting sites

    I have a problem that's probably destroying my server's popularity. My server's IP is creeperscreep.com, formerly creeperscreep.tk. I host it using MCProhosting. All of my votes get recieved yet when the server is pinged from the site, it shows offline. Players can connect just fine. The problem started a few weeks after I switched domains, in mid-January.


    I have four voting sites, only one works consistently. Votes go to the direct IP while players go through the connection path below.

    http://minecraftservers.org/server/261623 - Rare bursts of uptime

    http://minecraft-mp.com/server-s91577 - Up a quarter of the time

    http://www.planetminecraft.com/server/creepers-gonna-creep-3406636/ - Works properly

    http://www.minecraftforum.net/servers/563-creepers-gonna-creep - Haven't seen it up any

    Note: On the Minecraft Forum page


    From graphs of the uptime, it seems that there are tiny windows where it sees the server, but most of the time it is offline.


    My connection route goes like this, I have to use two domains because the port is different.

    1: creeperscreep.com goes to my secondary address using an SRV record to change ports. I use Cloudflare for DNS.

    2: my secondary address goes to the direct server IP with the correct port. That's handled by Freenom (.tk domains).


    I just turned off CloudFlare security to see if that's the problem but I don't think that'll help. I would really appreciate your help, because there's been a noticeable drop in players over the past month.


    Thanks.

    Posted in: Server Support and Administration
  • 0

    posted a message on World Protection

    You could either:

    Have the players in adventure mode.

    Install WorldEdit and WorldGuard, then make a region containing the arena and disallow block breaking.

    Either one works just fine, though it depends on how your server is setup.

    Posted in: Server Support and Administration
  • 0

    posted a message on How much ram does 2 people need?

    Are you constantly restarting your server? As the server runs, more and more of the RAM is used, and the server gets laggier.

    Posted in: Server Support and Administration
  • 0

    posted a message on Your own opinion
    Quote from BC_Programming»

    backseat moderator much?


    Oh no! My cover's been blown!
    Posted in: Recent Updates and Snapshots
  • 0

    posted a message on Your own opinion

    You can post your own opinion about the snapshot in the section.

    That's okay.


    Others may disagree.

    That's okay.


    You can start a flame war and attack those who disagree.

    That's not okay.


    After seeing some posts in this section I felt I had to make this.

    Posted in: Recent Updates and Snapshots
  • 0

    posted a message on Free Plugin.
    Quote from OakiepalX»

    For MC 1.6.4


    A plugin? For 1.6.4? Why are you running that version when you can run the latest?
    Posted in: Server Support and Administration
  • 0

    posted a message on Good anti-cheat plugin?

    I used Anticheat for a while, then I switched to NoCheatPlus because I found it annoying.


    However, it's not about what anticheat you use, it's how you configure it.

    Posted in: Server Support and Administration
  • To post a comment, please or register a new account.