• 0

    posted a message on Start File not working on forge server?
    java version "1.8.0_191"[/p]
    Java(TM) SE Runtime Environment (build 1.8.0_191-b12)[/p]
    Java HotSpot(TM) 64-Bit Server VM (build 25.191-b12, mixed mode)[/p]
    Posted in: Server Support and Administration
  • 0

    posted a message on Start File not working on forge server?
    [p]Hello![/p] [p]I am currently running on Mac OS X High Sierra 10.13.6 with 16GB of ram.[/p] [p]Whenever I try to run my forge server using start.command it doesn't work and gives me this error:[/p]

    [CENSORED]-iMac:~ [CENSORED]$ /Users/[CENSORED]/Desktop/FTBServer/ForgeLobby/start.command ; exit;[/p]
    A problem occurred running the Server launcher.java.lang.reflect.InvocationTargetException[/p]
    at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke0(Native Method)[/p]
    at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)[/p]
    at java.base/jdk.internal.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)[/p]
    at java.base/java.lang.reflect.Method.invoke(Method.java:566)[/p]
    at net.minecraftforge.fml.relauncher.ServerLaunchWrapper.run(ServerLaunchWrapper.java:70)[/p]
    at net.minecraftforge.fml.relauncher.ServerLaunchWrapper.main(ServerLaunchWrapper.java:34)[/p]
    Caused by: java.lang.ClassCastException: class jdk.internal.loader.ClassLoaders$AppClassLoader cannot be cast to class java.net.URLClassLoader (jdk.internal.loader.ClassLoaders$AppClassLoader and java.net.URLClassLoader are in module java.base of loader 'bootstrap')[/p]
    at net.minecraft.launchwrapper.Launch.<init>(Launch.java:34)[/p]
    at net.minecraft.launchwrapper.Launch.main(Launch.java:28)[/p]
    ... 6 more[/p]
    logout[/p]
    Saving session...[/p]
    ...copying shared history...[/p]
    ...saving history...truncating history files...[/p]
    ...completed.[/p]


    [Process completed][/p]



    [p]Whenever I run the server by double clicking the forgeuniversal.jar it works and loads everything fine.[/p]
    [p]The code I am using for start.command is:[/p]

    [p]#!/bin/bash
    cd "$( dirname "$0" )"
    java -Xms1024M -Xmx1024M -jar forge-1.12.2-14.23.5.2768-universal.jar -o true[/p]

    [p]Please help I have no idea what I am doing wrong.[/p]
    Posted in: Server Support and Administration
  • To post a comment, please or register a new account.