• 0

    posted a message on Reika's Mods (Tech, WorldGen, Civilization, and more)
    Quote from Reika»


    Also, these sprites look suspiciously like ones from Stellaris:

    https://i.imgur.com/jsioOFi.png


    They look like spell icons from the mod Ars Magica. ...actually, I think everything showing up in that particular image is from Ars Magica.

    Posted in: Minecraft Mods
  • 0

    posted a message on Reika's Mods (Tech, WorldGen, Civilization, and more)

    I do not have the technical knowledge to even know where to look for that. I just knew that I don't have Protection in the Chromatic Enchanter in my own game either, and remembered that line in the changelog, so it was an easy first mod to check for conflicts.

    Posted in: Minecraft Mods
  • 1

    posted a message on Reika's Mods (Tech, WorldGen, Civilization, and more)

    Testing for Protection in the Chromatic Enchanter:

    Only mods loaded are DragonAPI + Chromaticraft + NotEnoughItems = Protection is avalible.


    Added Thaumcraft, and Protection disappears. Perhaps related to "ChromatiCraft: Chromatic Enchanter can no longer do infusion enchantments" from V25a?

    Posted in: Minecraft Mods
  • 0

    posted a message on Reika's Mods (Tech, WorldGen, Civilization, and more)
    Quote from Reika»

    You (mostly) understand the process, and did at first follow the correct steps. However, it worked fine on my dev server and in testing. Additionally, the VM does not eat TNT and never has.



    Also, I recommend against giant posts with nine separate questions in them; they are nearly impossible to reply to.


    That's fair, sorry about that. Was attempting to avoid multiposting, but... yeah. Fair.


    Hm, I was assuming it was the VM eating the TNT entities after they were primed but before they exploded. Even if it wasn't the VM, something seems to have been causing them to not actually explode and then they were gone from the otherwise intact structure when I was able to reload the area.


    Unless the TNT exploding in the middle of the active structure is itself what's causing the issue, and then after restarting the server, the TNT is gone because it was primed by redstone, but everything ground to a halt before the explosion could actually destroy any blocks... Would I be correct in guessing that detonating the TNT is an intended part of the process, and is meant to be the actual trigger for sending the VM between the two structures?

    Posted in: Minecraft Mods
  • 0

    posted a message on Reika's Mods (Tech, WorldGen, Civilization, and more)

    Update on the Nether Dislocation Focus: Got the structure to complete by using a 5th redstone torch and some dust in the center to turn off the ones that would detonate the TNT (why is this not included in the structure page?). ...and the server promptly lagged out as soon as it tried to actually grab the Void Monster.


    Tried again with a redstone block instead of a torch - looks like the crash was from the structure trying to do it's thing even after being broken by the TNT being primed (VM ate the torch), then eaten by the VM before it could detonate.


    Now it's being added to my "Do I misunderstand?" list though. The way the Lexicon makes it sound like this should be working is: Dislocation Focus captures VM > sends VM to the Elimination Spiral in the Overworld > Elimination Spiral contains VM and slowly kills it. Step 1 is working fine, but that seems to be all that's happening.

    Posted in: Minecraft Mods
  • 0

    posted a message on Reika's Mods (Tech, WorldGen, Civilization, and more)
    Quote from Ieldra2»

    You may have to hold the elemental manipulator to see the effects.

    ...

    I got a new recipe for a shielded cell for AE2, apparently to safely store the artifacts, but I've rather played it safe and kept them in a chest so far.

    The casting delegate: I ran into the same problem with the Insertion Focus, and found that you can pull crafted items out with a hopper placed under it. I haven't tried other extraction methods yet - would prefer something faster - but for now I can get crafted items back into the AE2 system.

    ...

    Also, can you select an item to be crafted from NEI? I can use a sample, but that doesn't help with things of which you don't usually keep samples, such as energized cores.
    ...
    I didn't know the infusion stand accepts fluid connections. I've always refilled the pool with a liquid spiller so far. Where would you even place the connection?

    ...

    Meanwhile, I have a question about the personal infusion stand: you can put ether berries into it to fuel the infusion process, but I'm also shown an ingot that you can apparently also use for something. I haven't found an ingot that matched the icon, and none of the CrC alloys work. Do you know what that is

    ...

    Finally, since you've completed CrC, can you give me a hint about data towers? I never managed to figure out what I had to do after finding the first one. Also, is there a way to make it easier to find the first one? I don't really want to spend more hours on random exploration than I already did.





    I'll have to try while holding my manipulator, see if it makes a difference.


    They are used to make the last tier of Focus Crystal. Other than that and apparently trading with villagers, I don't believe they have any other current use.


    I'm using a ME Import bus with acceleration cards, currently. It works fine, but doesn't get around the issue of the insertion stand only having a single slot of buffer inventory, so if you do a large batch craft that outputs more than a single stack at once, only the first stack ever goes through - the rest just sits in the casting table's output. Compared to for example a chest, will accept the entire output at once.


    There should be a button that looks like the Casting Delegate on the top right of the NEI page. Clicking that will set it as the "active" recipe for your delegate. You do still have to have crafted it at least once manually before it will actually work, though.


    Infusion stand accepting fluids to fill it's pool was mentioned in the patch notes. I did actually get it to work 1 time, with Fluid Link Anchors. ...it then proceeded to void the rest of the 48 buckets of chroma in the RoC reservoir it was drawing from, and I was never able to get it to work again. (The fluid anchors voiding stuff thing is apparently a thing that's already been reported on the github issue tracker)


    More Ether Berries, if I remember right. The icons have 2 parts; the tier/buff, and then lower right is the item needed. I never did figure out the meaning behind most of the buff images.


    If you haven't already activated the tower you found, do that (use the manipulator). If it's the Alpha tower, that one directs you to all the rest, one at a time. The other towers all tell you where to go for the next two closest. As for actually finding them.... hm. Without being too spoilery, the towers occasionally interfere with the normal function of one of ChC's tools in a way that is extremely helpful in locating the closest one to your current location.


    EDIT: Is... is the Nether Dislocation Focus just a troll? that structure is unbuildable - no matter what order you place them in, the redstone will set off the TNT. The Elimination Spiral also doesn't seem to want to be recognized as a completed structure... (and has 2 random Shielding Stone in the center of the 3rd layer that feel like a mistake.) Figured out the Elimination Spiral; it actually only needs the 1 bucket of Luma placed in the center, even though the Lexicon shows that it needs 125 source blocks through the whole structure.

    Posted in: Minecraft Mods
  • 1

    posted a message on Reika's Mods (Tech, WorldGen, Civilization, and more)

    I love Chromaticraft, but at times the imprecise documentation leaves a lot of questions of "am I doing this wrong, or is it a bug?".

    In today's confusions:

    I've "completed" the mod (rebuilt the Monument and obtained the Aura Locus), and still have yet to find a single Unknown Artifact. I've tried everything that makes sense with the hints I've seen Reika give (looked around pylons, data towers, villages. Hung around in deserts, plains, savannas.) Even tried using Matter Phase to get a look just under the surface in the hopes that that would help, but either they're invisible to Matter Phase, or they just aren't there. At this point I'm left wondering if my world somehow just... didn't generate any, and in that case if there's some way (other than cheating in Creative) to force them to spawn.

    From the v25a changelog: "ChromatiCraft: Gave Aura locus many new effects, mostly centered around lumens"
    The Lexicon still shows the old info page for the Aura Locus, with the fertility effect. I've figured out that it seems to passively charge nearby constructs that take Lumen energy (or at least, it provides energy to the casting table), but has anyone found the other new effects?

    Couple things with the Casting Delegate. While it being able to process recursive recipes is awesome, it's also... kinda stupid sometimes. Can't tell if it's trying to do crafts out of order, or just not realizing it's missing some ingredients, but either way the result is the same. The Insertion Stand below the casting table, while great for early game, seems like a significant nerf to the Delegate. As far as I can tell you still need the Insertion Stand there for the Delegate to function, but the Stand itself is an inferior inventory to dump casting results into than even a regular chest, as it only has a single slot and removes the option of putting an ME interface there to dump directly into a ME system.


    Fabrication Duplication doesn't seem to work properly with either the Item Fabricator or Infusion Stand. Item Fabricator stops working entirely if Duplication is active, and the Infusion Stand will consume the Raw shards and chroma, but I only seem to actually get a result out it it ~1/4 times. (Also, though the Infusion Stand will accept fluid connections now, it doesn't seem to actually... accept fluids.) It also seems to cause issues whenever it tries to put a stack of 2 of an item that isn't supposed to stack in the casting table's output.

    Was there a change to only allow a single Lumen Tree on a network? In the image here I have 2 trees that as far as I can tell are identical, but the one on the right both doesn't receive any lumen (looking at it with a manipulator just shows a blank circle), and isn't recognizing the Enrichment structure under it. (I did test putting another repeater that was very definitely in range and LoS of the right tree, still nothing. I can even switch the Battery blocks between the trees, and the left one stays the only one that works.) Lumen Trees need sky access! I'd missed that a floating island above it was overhanging it by a single block.

    Quote from Ieldra2 >>
    @Riyshn:
    That sounds like a lot has changed in CrC's late game in the last 18 months. Looking forward to it.

    @all:
    I have encoountered a curiosity. I have automated CrC alloying. Not with the alloying tank - too expensive in liquid chroma - but with standard dropping mechanisms like Item Inserters, and automatic liquid placing with AE2. Everything works really well....except for chromastone. Making chromastone appears to work only if I manually throw the ingredients into the pool. If I use any mechanism, such as an Open Crate from Botania, the ingredients go into the pool and nothing happens. I can even pick them up and throw them in manually, and *then* the alloying will start. Or I can pick them up and put them into a chest from which they're piped into an open crate, and it will again NOT work. I have repeated this several times, and this behaviour is perfectly reproducible.

    So why is that? It's not a big thing since I can autocraft all the ingredients and get them into one place, so what's left is not much of a hassle. I don't need hundreds of chromastones anyway, but I'm peeved that I can't get my automation to work.




    I'm actually more surprised the other ones did work. What I suspect is happening is the items aren't being dropped in by you, so the game doesn't have your progression data to confirm that the craft is allowed to happen.

    Posted in: Minecraft Mods
  • 0

    posted a message on Reika's Mods (Tech, WorldGen, Civilization, and more)

    Love the new exit from Proxima - much cooler than having to randomly dig for it. Especially with the amplified Fortune effect making the caves a good source of Purification Powder, when previously to get anything similar you basically had to go out to the Far Lands and find... I can't remember the name of the biome that usually had a ton. Much better all around. I do wish there had been some indication on first visit about the interaction limitations, though - I kept breaking things or trying to open chest and then... waiting, because it just looked like lag from chunk generation was delaying it.


    With the new exit method though, the design of the puzzle structures feels a bit... outdated? Specifically, the how the exit forms after acquiring the core and places you down near bedrock. Previously if you didn't have flight to get back out the entrance (or the specific puzzle made that not an option), the exit left you fairly close to bedrock and you could find a hole to drop through. Now, not so much.


    Is it normal that I keep having to re-tune my portal? Every 2 or 3 trips to Proxima it seems to just lose lose everything it had unlocked.

    Edit: Is there any way to set a structure/block as globally usable? For example, wanting to set up a network of Transposition Gates that can be used by anyone, without having to key everyone into each gate?

    Posted in: Minecraft Mods
  • 0

    posted a message on Reika's Mods (Tech, WorldGen, Civilization, and more)

    I'm running into a couple things in Chromaticraft that have left me wondering if they're bugs, or if there's something I'm just missing. Hoping someone can help.


    Found and activated my first Data Tower (the Alpha tower, if it makes a difference). From what I understand, the tower should now be pointing me toward another, but the particles that looks like they're intended to be the guide for that just... rotate smoothly through the full 360 degrees. Am I misunderstanding something about how to read this, or is the Alpha tower specifically just not helpful in finding the others?


    I am unable to interact with the Memory Crystal's puzzle. Anywhere I click on it just causes the whole thing to flash red and make an error sound at me. I assume there's something else I need before I can start on it?


    Unsure if this one is actually a real problem or just a display bug, but the pylons I've networked with the Memory Crystal seem to sometimes just... forget they're supposed to be networked? At least according to the overlay from the Pylon Compass. You can see in the image here the Kurauri pylon has an active Pylon Network Node at it's base, but the compass overlay doesn't register it as networked like it does with the Galazio one a bit further out.



    Has anyone figured out what the 8 runes on the top of the Casting Personalization page are for, or is there a hint anywhere? Only thing that made sense to me to try was replacing the blank stone in the top part of the casting structure, but that just resulted in an invalid structure.


    Not sure if this is intentional design or just an oversight, but getting the wooden Lumen Repeaters to work is really annoying, when you can't ping them to check connectivity. The range halo helps, but also isn't perfectly accurate - I've been seeing it "wobble" by up to 2-3 blocks sometimes.

    Posted in: Minecraft Mods
  • 0

    posted a message on Reika's Mods (Tech, WorldGen, Civilization, and more)

    A quick questions about the Knowledge Entanglement Pedestal, concerning this part in the lexicon entry:


    Requires that both players have similar progression at the time of linking.
    If the two players have different progression, the other will be made to match, possibly forgetting some of their progression.

    Both players are still required to be involved for some progress.


    Does this mean that if two players are linked, it's possible for one to block progress for the other? For example, if one of the players were to stop playing on the server, would their linked partner just hit a wall and be unable to continue with progression?


    And if that is the case, is there a way to unlink progressions in the case something like that happens?

    Posted in: Minecraft Mods
  • 0

    posted a message on Reika's Mods (Tech, WorldGen, Civilization, and more)

    If I'm reading this right, it looks like you accidentally introduced a Thaumcraft dependency: https://pastebin.com/y7Fa5KPZ

    Posted in: Minecraft Mods
  • 0

    posted a message on Reika's Mods (Tech, WorldGen, Civilization, and more)

    I've having some trouble getting the Knowledge Entanglement Pedestal to work.


    Myself and Friend have (as far as we can tell) identical progress - same entries in the book, same colors discovered, both bring up blank fragments.


    Process:

    I've built the Pedestal structure. Beam of light above it stays on, which I assume means it's assembled correctly.

    Friend stands on the Pedestal.

    I click the Pedestal with the manipulator.

    On my screen: Friend floats for a bit with a ball of light below him, before a tone plays and he's back to standing.

    On his screen: Nothing happens.


    We've tried having him build the Pedestal and reversing the roles, and it's the same - person activating it sees the floating animation, person standing on it sees nothing. Also tried building a second Pedestal and activating both at the same time; still nothing.


    No obvious indication that our progress is now supposed to be linked, and unless we've just had the bad luck to only try to test with progresses that are on the list of "have to be done separately", it's definitely not working. (World Floor, Evil Realm, whatever the one for drawing from a pylon the first time is called, Magic Liquid, Liquid Effects, and discovering 3 different colors).


    Are we missing something? Is it just broken? Is there more information I can provide that might help?

    Posted in: Minecraft Mods
  • 0

    posted a message on Thaumcraft 6.1.BETA26 [no longer being developed]
    Quote from praecipitator»




    You need to scan a crimson cultist and read crimson rites.

    Then you should get the eldrich research on the first page of the thaumonomicon.

    It was somehow like this:

    Crimson Cult --> Crimson Rites --> Eldrich <-- Auromancy

    Researching that unlocks the Eldrich tab. No idea if you have to be mad for this. I have been quite mad, but now I doubt this was necessary at all.





    Do we have any idea how to spawn/where to find cultists?

    Posted in: Minecraft Mods
  • 0

    posted a message on Thaumcraft 6.1.BETA26 [no longer being developed]

    No, don't nevermind! I'd like the answer to that question as well!

    Posted in: Minecraft Mods
  • To post a comment, please or register a new account.