• 1

    posted a message on Xaero's Minimap 1.17 Fabric (+ Forge | 1.16.5 | 1.15.2 | 1.14.4 | 1.12.2 | 1.8.9 | 1.7.10 and more)

    I know it's not my place to help troubleshoot, but since the crash seems to be complaining about a lot of rendering stuff, it might be worth asking them to update their gpu's drivers as well. Their GTX 660 is on driver version 456.71, whereas the current latest is 461.40.

    Posted in: Minecraft Mods
  • 1

    posted a message on Xaero's Minimap 1.17 Fabric (+ Forge | 1.16.5 | 1.15.2 | 1.14.4 | 1.12.2 | 1.8.9 | 1.7.10 and more)
    Quote from xaero96»

    I think CurseForge does the job pretty well: https://www.curseforge.com/minecraft/mc-mods/xaeros-minimap/issues

    I might make the source public in the future, but not very soon. I originally made the mod back when I barely knew how to code so I'm honestly embarrassed over a lot of the code (and I'm still learning). I'll have to do some major refactoring before I go that route. And it's not easy to refactor when I support so many different Minecraft versions. Plus I'm prioritizing stuff that actually matters to the average mod users :S


    Oh, I forgot you had the mods on CurseForge as well. I mean, yeah, I guess their issue system works. I haven't ever used it before, so I'll have to give it a poke when I next have a reason to open one.


    Well, if you do ever choose to make it public, I feel like as long as you explain what you just did, very few people would likely comment on it. That said, as wonderfully as your minimap and world map work, I want to doubt it's as poor as you assume it is. Code doesn't have to be pretty looking to be good code.


    Yeah, it's nuts how you support so many versions. Even highly experienced developers who I'd call professional, like "nossr50", the creator of the server plugin, "mcMMO", struggle with multi-version support. On his "overhaul" of the plugin, he only has 1.13 to 1.16.1 right now, and has been trying to figure out how to support older versions.


    I really do think that you don't give yourself enough credit. You do awesome work.


    As always, thank you for the response.

    Posted in: Minecraft Mods
  • 1

    posted a message on Xaero's Minimap 1.17 Fabric (+ Forge | 1.16.5 | 1.15.2 | 1.14.4 | 1.12.2 | 1.8.9 | 1.7.10 and more)

    Thank you so much for adding fabric support!





    Your minimap and world map were the only two things left that were keeping me on Forge. They are essential to me, for me to play Minecraft in any context. My friends have been bugging me to move to Fabric for a while now, lol.

    Posted in: Minecraft Mods
  • 2

    posted a message on Xaero's World Map 1.16.5 Forge [Fabric | 1.15.2 | 1.14.4 | 1.12.2 | 1.8.9 | 1.7.10 | more]
    Quote from nada1998»

    Hi, I've been using your mod for a couple of weeks now and I love it. But yet I didn't figured out how to create an image of full world. When I go to mods doesn't allow me to click on config. Or is it somewhere else? I couldn't find a guide for this, can you make one step by step?

    I play on singleplayer. thanks :D


    The settings for the world map are not in Forge's mod settings. Xaero has his own ingame settings menu, which I have bound to the F9 key. I don't recall what the default is, but check your keybinds to see.



    It has its own section of keybinds:







    This is what the settings menu looks like, and the button you need to use:




    Posted in: Minecraft Mods
  • 2

    posted a message on Xaero's Minimap 1.17 Fabric (+ Forge | 1.16.5 | 1.15.2 | 1.14.4 | 1.12.2 | 1.8.9 | 1.7.10 and more)

    Hello, got a question about optifine compatability,

    In update 20.7.1 you state that you fixed safe mode compatibility with Optifine for 1.15.2. How is that possible when we need forge which is not supportet by the latest pre release of optifine


    There is an open source project called "OptiForge", which aims to add Forge support to OptiFine's 1.15.2 previews. It was created by one of the main contributors to common Forge issues, Zeker: https://github.com/ZekerZhayard/OptiForge


    This is what Xaero was referring to.

    Posted in: Minecraft Mods
  • 3

    posted a message on OptiFine HD (FPS Boost, Dynamic Lights, Shaders and much more)
    Quote from G3NSVRV»

    OptiFine 1.15.2 HD U G1 pre13, Shader Resource pack stack trace

    bare-bones-normals-0.3




    Please use the GitHub. As I said above to another person who posted an issue here:


    Quote from Quavelen»


    You need to post this on the GitHub: https://github.com/sp614x/optifine/issues


    Unfortunately, the thread is rarely checked by sp614x. He responds to issues created on his GitHub fairly quickly.

    Posted in: Minecraft Mods
  • 1

    posted a message on Xaero's Minimap 1.17 Fabric (+ Forge | 1.16.5 | 1.15.2 | 1.14.4 | 1.12.2 | 1.8.9 | 1.7.10 and more)
    Quote from xaero96»

    Thanks for reporting! I have already received a report for this but I appreciate it either way. It's a compatibility issue in the world map mod and I'll fix it in a future update.


    Yup, you're welcome. =)


    I'm glad it's something you're able to fix, then. Also, I guess I goofed up and misread the crash report lol. I read it as minimap, not world map, which is why I posted it on this thread instead of the world map one.


    Since it's on your end, I went ahead and commented that on the issue I opened on OptiForge and closed it.


    Thank you for responding.

    Posted in: Minecraft Mods
  • 1

    posted a message on Xaero's Minimap 1.17 Fabric (+ Forge | 1.16.5 | 1.15.2 | 1.14.4 | 1.12.2 | 1.8.9 | 1.7.10 and more)
    Quote from xaero96»

    Quote from Rhyagelle»

    Quote from xaero96»


    Every server should have a plugin for permissions though. Why not get one?





    I'm not the admin, just trying to help the admins so that the average player can TP. We don't really understand all this stuff so we thought the mod would handle it. How would I go about looking for these plugins?





    I don't know much about server plugins nowadays but you'll definitely find something if you Google it.




    Well, currently the most common plugin used is called "LuckPerms". It is compatible with both Paper and Spigot, and can be found on the Spigot website: https://www.spigotmc.org/resources/luckperms-an-advanced-permissions-plugin.28140/ Prior to this, the most common plugin was called "Permissions Ex". Unfortunately, it was abandoned long ago.


    I would suggest pairing LuckPerms with the EssentialsX plugin, which is the current iteration of Essentials. It overrides most of the vanilla commands, and adds proper support for a permission plugin. You can find it here: https://www.spigotmc.org/resources/essentialsx.9089/ It's worth noting that 1.15.2 support for EssentialsX is still in development builds, found on their Jenkins listed on the Spigot page. The latest 'release' build is still only for 1.14.4, so make sure to grab the correct version.


    Once you have both EssentialsX and LuckPerms, you would just need to add the permission node "essentials.tp" to the default group. Bear in mind that doing this will allow all players to teleport to any coordinates, and any other players at will. So, I would suggest manually adding the permission to players you trust rather than allowing it globally. If this isn't a concern however, then by all means do the former.


    If you decide against using EssentialsX, then the vanilla permission node is instead "minecraft.command.teleport". Either way, this node can be added via ingame command or via the config files. I would suggest using the ingame command, due to the tab complete support - it makes it much easier, and quicker. Please see the well documented wiki pages for the command syntax linked on the Spigot page.


    (Source: I've been doing Minecraft server management since 2012; still doing it to this day.)


    Hopefully this helps.

    Posted in: Minecraft Mods
  • 3

    posted a message on OptiFine HD (FPS Boost, Dynamic Lights, Shaders and much more)

    It's happening! Forge support has been added to the latest OptiFine Preview today, 1.14.4_HD_U_F4_pre1.





    Make sure to click on "preview versions" when on the download page, to access this version.

    Posted in: Minecraft Mods
  • 1

    posted a message on OptiFine HD (FPS Boost, Dynamic Lights, Shaders and much more)
    Quote from NexusTheBrony»

    so... looks like a mistake was made making OptiFine 1.14.3 HD U F2 or at least the changelog. the changelog says its compatible with Forge 27.0.51, but trying with that and 27.0.60 Forge says its an unsupported mod and won't run it


    Posted in: Minecraft Mods
  • To post a comment, please .