• 0

    posted a message on Reika's Mods (Tech, WorldGen, Civilization, and more)
    Quote from ewsmith»
    Umm... Yea, how are you all actually getting the 1.7.10 versions to launch? No matter what I do I keep getting an IllegalAccessError crash. Even if I only have forge and dragonapi installed.

    Not sure what you've done or not done, aside from trying other Forge versions.

    I generally play modpacks, but have dabbled in assembling my own from scractch. To that effect, have run the Forge-1208.exe installer against my vanilla Minecraft, and try throw stuff at it occasionally. Also to troubleshoot mod bugs in a minimal environment.

    After reading your post, I created a new instance, selected my Forge 10.13.0.1208 option, then launched and quit it. Dragged in unmodified V1b verions of:
    DragonAPI
    RotaryCraft
    ElectriCraft
    ExpRedstone
    GeoStrata
    ChromatiCraft
    CritterPet
    UsefulTNT

    Fired it up, and it launched right into the game, no problems. I still need to find info on the Chromaticraft musical structures, as I have no idea what they do or what they're good for, other than killing me whenever I get close. But more importantly, his mods work fine with just Forge and various Dragon/Reika mods only.

    I noticed getting killed by the musical structure didn't drop me from the game this time, so my prior issues in BTP likely an interaction with one of the many mods it contains. I captured the below information though.


    On-screen error when killed by the structure, and crash out of the game:

    Connection Lost

    Client multipart @(572, 49, 58) not found

    From my Forge log:

    [23:32:26] [Server thread/INFO]: pjfranke was killed by magic
    [23:32:26] [Client thread/INFO]: [CHAT] pjfranke was killed by magic
    [23:32:29] [Server thread/INFO]: pjfranke lost connection: TextComponent{text='Disconnected', siblings=[], style=Style{hasParent=false, color=null, bold=null, italic=null, underlined=null, obfuscated=null, clickEvent=null, hoverEvent=null}}
    [23:32:29] [Server thread/INFO]: pjfranke left the game
    [23:32:29] [Server thread/INFO]: Stopping singleplayer server as player logged out

    Posted in: Minecraft Mods
  • 0

    posted a message on Reika's Mods (Tech, WorldGen, Civilization, and more)
    I've been playing 1.7.10 via the Bevo Tech Pack, currently using v9a. I added a few other mods to it: Thaumcraft, Morph, Attachable Grinder, and re-added Aroma's Dimensional World after it was pulled. Playing a SSP game.

    Made a copy of the pack, and after I added DragonAPI and Rotarycraft, and had the same issues with the APIs as mentioned by others for IC2 and Buildcraft. When I replaced the included API folders with the ones from the copies of BC and IC2 I have downloaded, those errors were fixed. After adding Electricraft, Geostrata, Chromaticraft, UsefulTNT, and CritterPet, I ran into the previously mentioned biome ID error between Chromaticraft and Biomes o Plenty. Changed 47->147 and 48->148, and I was able to launch and open my map successfully.

    The next error I had was when I approached one of the Chromaticraft structures that starts playing music and attacking you when you're too close. Upon death, it seems to have crashed the internal server, and kicked me back to a screen, then back to the "join server" page. I can close that, reselect single-player and re-join my map OK. I was playing on my other system, and unfortunately it was late and I got lazy so I don't have the exact error, or a crash log. Will update when I can get those. Mostly noting my similar experience for others, not meant to be a "Hey Reika, fix this!" post.

    OH yeah, BTW Reika, I noticed the Chromaticraft download is still ~40MB. Hadn't you mentioned you going to remove some files that unintentionally got included?

    edit: On-screen error when killed by the structure, and crash out of the game:

    Connection Lost

    Client multipart @(572, 49, 58) not found

    Ah! From my Forge log:

    [23:32:26] [Server thread/INFO]: pjfranke was killed by magic
    [23:32:26] [Client thread/INFO]: [CHAT] pjfranke was killed by magic
    [23:32:29] [Server thread/INFO]: pjfranke lost connection: TextComponent{text='Disconnected', siblings=[], style=Style{hasParent=false, color=null, bold=null, italic=null, underlined=null, obfuscated=null, clickEvent=null, hoverEvent=null}}
    [23:32:29] [Server thread/INFO]: pjfranke left the game
    [23:32:29] [Server thread/INFO]: Stopping singleplayer server as player logged out

    Potentially there's been an update (haven't caught up with the rest of today's posts yet...) and this is irrelevant.
    Posted in: Minecraft Mods
  • 0

    posted a message on Reika's Mods (Tech, WorldGen, Civilization, and more)
    Quote from Reika»
    I should be able to release V1, the first official update for 1.7.10. I do have some new features I added during this time, including the turbine flywheel.

    Previously when I asked about using the alpha release, you advised against adding it to existing 1.7.10 worlds, as changes being implemented would cause issues upon update.

    Will this release have the same problem with upcoming (next month or two) updates? Or not for the foreseeable future, as the referenced changes have now been implemented? Looking forward to getting an extractor in my map ASAP. :D
    Posted in: Minecraft Mods
  • 0

    posted a message on Reika's Mods (Tech, WorldGen, Civilization, and more)
    Quote from Reika»

    The mods have been released, and will be again soon, but your world will not survive.

    I realize you were responding to someone wanting to move a 1.6.4 map to 1.7.10. That said, should I have to worry about many changes if I run the jar you posted already in my 1.7.10 map, once you release updates? I figure at worst, if there's worldgen for an included mod I don't use once you re-post more polished versions, I'll end up with empty holes.

    Related question, does that jar do retro-gen? Or new chunks only?
    Quote from Keybounce»
    So, this reviewer wants every mod to behave in the exact same way.
    Never mind that BM is very, very different, or that actually trying to progress past the second level requires serious work and major automation of mob farms, or that the higher levels are all *massive* drains on your life force (just ask anyone that actually tried to use the loot rewards that Jaded gives out without a set up blood network ... something like 100 hearts of damage at once.

    The Master Blood orb, which needs 25,000 LP to make? And then you mean the bound tools? Yeah, those could be evil. :D

    In my BevoTech Pack 1.7.10 map, I cured two zombie villagers with syringes, then let them breed a bit around a bunch of doors. Snagged one in a safari net, and cloned him about 15 times right on top of my altar in an auto-spawner with a drum of mob essence and a hardened energy cell. Don't yet have a prettified area yet, but it worked good enough. Toss my block of gold, then stab villagers at 2000 LP each until I had my orb. It was a bit of a hurdle, considering I needed to have killed a blaze, 4 endermen, and a ghast first.
    Quote from Turrah»
    Hope this mod gets ported to 1.7.10

    It is/was...there's an alpha (IMO) that was released for initial testing a page or three back.
    Posted in: Minecraft Mods
  • 0

    posted a message on Modpack Spotlight - Agrarian Skies
    Quote from BobbyBlox

    What is the mod doing the backups in this pack and is it configurable like forge servertools? I'd like to specify how many backups to keep, the frequency and the location if possible.

    And what is the approximate randomization of rain? I've had the server run for over 7 hours with no rain. When I first started the server it rained, but it hasn't since.


    One tip I've read, was you can use the hammer to work cobble down to sand, smelt that in the oven, and get some glass bottles. Use those to pick up water from your pond (make sure from a spot the source block will regenerate!), then use the waterbottle to fill your barrel. That will let you add dust to make clay, to make a clay bucket and a crucible for lava creation. The lava will destroy the clay bucket on use, but once you have a bucket worth of lava you can make your cobble generator, then easily make another bucket. Also sieve enough gravel to get iron ore, and make an iron bucket.
    Posted in: Minecraft News
  • 0

    posted a message on Reika's Mods (Tech, WorldGen, Civilization, and more)
    Quote from megamadman7

    Your right.... the extractor is processing ores very slowly, even with the torque and speed being multiplied by 32x in the CVT unit. Am I not overclocking it correctly or should I just use something with a higher ratio, like a high-ratio gear?

    Quote from megamadman7

    Hey, I'm having issues with the extractor from RotaryCraft.

    I have an AC engine powering a CVT unit that has all 33 belts in it, which is powering the extractor. I have a redstone clock from Expanded Redstone alternating the mode from torque to speed every few seconds. Also, the ratio IS set to 32 for both, and i'm pumping water into the extractor, but for some reason I when I put raw ores into the extractor, it refuses to process them. I checked and everything is setup correctly. Can anyone help me out here? I'm not sure If this is a bug or if i'm just missing something.


    You need a LOT more speed than that for FAST processing. As is, it'll eventually get through, and for free with the AC engine. Like I just mentioned for my magnetizer setup (if this doesn't merge my posts), I'm also using here a CVT at 32x and a 16x gearbox, both set for speed. However, the CVT also switches to 1x mode for the higher torque stages. This is toggled with PRC on a 10sec cycle time. Power is is from 4 magnetostatics to ensure the required torque at that high speed. See at http://i.imgur.com/MTwv94R.png

    Check the GUI (you may need to turn off NEI to see it) and ensure your extractor is getting the required speed and power at all 4 stages....that would likely be why the ores aren't processing.

    The High Ratio gear would help, if you have the power behind it to ensure the necessary torque. Two stages of mine are running at 2048rpm into 512x speed (~1M rpm, 16nm), the other is only 16x speed (32k rpm, 512nm. No complaints on ore processing speed, as my ore mining speed is quite slow in comparison.
    Posted in: Minecraft Mods
  • 0

    posted a message on Reika's Mods (Tech, WorldGen, Civilization, and more)
    Quote from McJty

    I'm now feeding it 128k watts at 4096 rad/s. Shouldn't that be more then sufficient?


    No idea if you got this working well already or not...sorry, there's a LOT of pages still for me to read through.

    4096 rad/s is your issue. The vanilla 1-clock timer was plenty fast IMO. I was seeing the same slow performance you were, until I upped the RPMs...at 2^20 RPM (~1,000,000), it works quite well. That was a magnetostatic at 2048rpm, with a 32x CVT, and a 16x gearbox.
    Posted in: Minecraft Mods
  • 0

    posted a message on Reika's Mods (Tech, WorldGen, Civilization, and more)
    Quote from melanclock

    Just signed up to tell you that this is mindblowingly awesome! I saw some screenshots a while back and thought "meh it's probably alright" but actually looking into Rotarycraft has me speechless.


    Heh, wait until you start making use of the advanced machines!

    I had been manually collecting canola seeds, grinding, and feeding hydrokinetic engines. This was an absolute PITA, so I stopped using those engines.

    Had 2 grinders hoppering the dusts for tar, netherrack dust, etc for jet fuel production. Incredibly slow, and seemed not worth it.

    Had an extractor setup, and while the duplication was nice, it would take quite a while to work it's way through a stack of ore. Not nearly fast enough to make full automation worthwhile.

    Then one day I got motivated, also decided to actually give the A/C engines a shot...built a fan and vacuum powered canola farm with 4 9x9 plots into 8 grinders...canola up the wazoo now. 2 gang automated ethanol production, within a few hours had burned through my sugar stacks and had 100K+ ethanol. Same 8 grinder setup as above for soulsand and netherrack grinding to distill jet fuel. And went from a single magnetostatic to 4, with 512x and 16x stages on my extractor. Ores FLY through there now.

    It went from a "Eh, this is kind of neat. I do like the unbreakable looting sword and silk touch pick" mod, to a "holy crap, this is awesome!" mod. My next steps were making use of the massive jet fuel stores to run borers, but then I pulled all my engines and gearboxes to upgrade RC, and haven't gotten everything straight yet.
    Posted in: Minecraft Mods
  • 0

    posted a message on Reika's Mods (Tech, WorldGen, Civilization, and more)
    Quote from Reika

    ...makes canola grow faster...


    Faster?? I'm finally getting into the advanced automation aspects of your mod (crazy fast extractor processing, 2-stage (+ 2x parallel) ethanol production, wheat & canola farm with fans, item vacuum, etc), and just the other night added sprinklers to my canola farm. I'm now getting crazy amounts of canola seeds now from only two 9x18 farm plots (minus 4 spots for ground sprinklers)...I already can't keep up with 8 grinders on 2 steam engines, and have WAY more lubricant than I need.

    And you think it needs to go faster?!? More power to ya!
    :steve_sillyface:
    Posted in: Minecraft Mods
  • 0

    posted a message on Reika's Mods (Tech, WorldGen, Civilization, and more)
    Quote from 7thfleet

    ...and would probably happen with wrathlamps.


    No issues on my map, several wrathlamps in use in areas with Rotarycraft machines. OTOH, does anyone know if the invisible blocks only exist after a certain level? That is, if your lamp is only 8 block above the floor, vs 30 blocks, are they still present?
    Posted in: Minecraft Mods
  • 0

    posted a message on Reika's Mods (Tech, WorldGen, Civilization, and more)
    Quote from McJty
    Is there a way to speed up the magnetizing unit? I'm magnetizing a tier 2 upgrade to 720 microteslas and it takes ages (about 10 seconds for every microtesla).
    Here's my setup...one post-nerf, pre-upgrades magnetostatic, plus 2 CVTs at 32x mode. Goes faster the more speed you give it. Redstone clock is provided by the rednet controller, on a 1-count square wave (timer) output.
    Quote from McJty
    Just something that I think would be useful. It would be nice if you could somehow (through a redstone signal for example) detect if an extractor (or any other RotaryCraft machine for that matter) is actually doing something so you could automatically cut the power once it stops processing ores. This can be very handy in case you're powering your rotarycraft machines of an RF network.
    Reika already mentioned a comparator, but I haven't bothered with that. But with cobblestone structure pipe, at minimum 2 Iron OR gates, and some pipe-wire, I've got the below setup that turns off once all processed ores have been removed via an ME import bus.
    If there's items in inventory, it sends a pipe-wire signal to the other gate, which outputs a redstone signal on pipe-wire input. That kicks on the 4xmagnetostatics, running into a CVT set to 1x and 32x mode, toggled every ~10 seconds or so by the RedNetController. That outputs via a bevel gear into a 16x gearbox in speed mode. With the 4x engines, there's enough torque to run at 16x speed and run stages 1 and 4 quickly. Then it switches to 32x mode (effective 1,048,576 rad/s), and stages 2 and 3 zip right by.
    Quote from Archervenom
    Could I please see a picture of a working solar power plant thingy. I don't really understand it
    20 boilers, 80 (plus 1 broken) mirrors. No melting base, 5.2MW of power at full sunlight. Marginal lag IMO.Hehe, it will light players on fire though! :)
    Reika, THANK YOU for this. I wasn't using enough rads/NM/power/etc the first time I tried it, but now that it's working I LOVE this block. No more annoying rain!

    Posted in: Minecraft Mods
  • 0

    posted a message on Reika's Mods (Tech, WorldGen, Civilization, and more)
    Quote from Archervenom

    It's midnight where I am and I need to get to sleep so I can't Chech right now, but does the dynamo included in the mod need rotational power to generate RF, or is the other way around?


    The former, not the latter.



    Posted in: Minecraft Mods
  • 0

    posted a message on Reika's Mods (Tech, WorldGen, Civilization, and more)
    Quote from Zero5211
    I set my own limits on what I cheat for. Accidentally left Minecraft open and Creeper found me and exploded my base? I have no problems with spawning in the blown up blocks. Or if I thought I set up something correctly, but forgot something that was only mentioned in passing and it causes an irreversible reaction, I'll spawn things in to fix it. I won't cheat for things I need to gather resources for however. Basically, I don't want to lose 10 hours of progress due to 5 seconds of misfortune.

    (sorry to drag up an old post...I'm working my way through to the last page, wanted to put my $0.02 in here)

    That's what frequent backups are for! My example? Grabbed the wrong Industrial Coil...had been charged in V15b to 360GJ, slightly over the limit now. Thought it was my empty one, was planning to charge it from a jet turbine right in the middle of my base.

    Fudgesicle.

    THAT left an impressive hole! Unfortunately, the last backup was 5 days old...thankfully, not much had been done that was reverted. BTW, did y'all know a creative coil is considered to be "full", so putting any charge into it seems to have the same effect? Yeah...happened again. Thankfully at (what I thought) was a remote charge station....not far enough from the RF power generation though. Rolled back to last nights backup again today!

    Also, someone showed a method with a piston and restone block for shutting down the bedrock breaker. Thanks for that, it works great! Using the RedNetController blocks/wire for it, to have a timer toggle the (non-sticky) piston. This ensures it will still push shortly after the last block is broken. As I work my way across, I can just keep extending the end of the 3 RedNet wires, though the coil, gearbox, and breaker have to be moved. No wasted energy though!


    Reika, 2 questions. Sorry if these have been answered in-between page 317 and here. To not over-charge an industrial coil, I remember reading they'll output a redstone signal. Is that just an on/off for fully charged, or does it ramp up the closer to full you get? If I replace the coil with a torch in the below setup, it will then send a signal to the magnetostatics to turn them off. Does this mean the coil will similarly output a signal to stop the charging when at 100% (or very close, to prevent over-charging)?

    (this is where I had the 2nd accident, using the creative coil to test the "full" signal output)

    Secondly, if I have but one complaint, it's your prolific output. Wah. You're constantly fixing bugs, and adding new features. Actually, not a complaint; that's really awesome. Unfortunately though, the modpack my server runs (TechWorld2) doesn't keep the same pace. TW2 1.1.4 only has RotaryCraft v16c. This means I got the first step of the nerf of magnetostatics, but not the subsequent upgrades you added. If I had but one wish, it would be for milestone releases...or I suppose a modpack that updated more frequently would work too! :mellow: Crazytalk, I know. I'd update the files in the pack manually (and add your other mods), but my whiney friends don't want to have to manually manage their install. Sooo..we're stuck with v16c until the pack updates, or we find a way to run all the same mods with a 1-click installer.

    Oh wait, that wasn't a question...2nd question: For an overcharged coil like I mentioned above...can I do anything useful with it? Or just use it for evil, as a bomb? :D
    Posted in: Minecraft Mods
  • To post a comment, please or register a new account.