• 0

    posted a message on Zyin's HUD
    Is there anyway to get this to work without Forge?



    I have to use LiteLoader for my MiniMap Mod & whenever I try to run forge it doesn't let me select my LiteLoader jar/profile, it just creates its own independently.



    If I run the LiteLoader installer on the Forge jar/profile will that work?



    Any help is appreciated~
    Posted in: Minecraft Mods
  • 0

    posted a message on Sonic Ether's Unbelievable Shaders [compatible with Minecraft 1.12.2 via OptiFine]
    Does anyone have an album of the differences in Light, Standard, Ultra, DOF, etc?
    Posted in: Minecraft Mods
  • 0

    posted a message on Better HUD: Customizable Vanilla HUD and 25+ New In‑game Widgets
    Wish this worked with Lite Loader
    Posted in: Minecraft Mods
  • 0

    posted a message on LiteLoader
    That installation trail looks pretty good. i can't see any problems.

    Only one thing that irks me: *dialogue
    I know you're probably going on American English, the other version just looks a bit nicer in my opinion.

    Edit:

    You'll have to increase the memory allocation in the launcher profile. I usually give it 3GB but it depends on what your machine has available. Just remember to leave a bit free for the operating system.

    In the launcher you would go to Edit Profile and there is a text box labeled JVM Arguments. Somewhere in there you would look for and argument that looks like "-Xmx1G". You would change that to "-Xmx3G" to give it 3GB or, if it's not there you can just add it in.

    This worked. Thank you very much!
    Posted in: Minecraft Mods
  • 0

    posted a message on LiteLoader
    I'm not sure why I'm such a failure at this ~__~

    This once ran fine, loaded OptiFine, Shaders, and my Shader pack and Texture Pack. After trying to include the VoxelMap mod I kept getting stuck at 'Reloading Resources'

    To backtrack to see if it was the VoxelMap or not, I removed the VoxelMap mod & now even if VoxelMap is not in the mod folder, it gets stuck on Reloading Resources

    No other modifications are installed. No mods no nothing else

    The problem seems to be related to loading up LiteLoader with Sphax PureBD 256x. I'm not sure if the problem is coming from the texture/resource pack or LiteLoader though. Either way I wanted to let you know/report it

    Problem Found: http://puu.sh/eSbCj.png

    My assumption is minecraft can't load with OptiFine, ShaderMods, ShaderPack, LiteLoader, a Mod, and a 256x texture pack

    Not sure how to fix this or what to do about this
    Posted in: Minecraft Mods
  • 0

    posted a message on LiteLoader
    You helped me so I'd love to help give some feedback. First thing I noticed: http://puu.sh/eS9zH.jpg Tweaks*

    Other than that it looks great & would have cleared up any confusion I once had
    Posted in: Minecraft Mods
  • 0

    posted a message on VoxelMap [1.16.1 to 1.7.10] - a minimap and worldmap

    You are seeing this message because an event callback was injected by the Event
    Injection Subsystem but the specified callback class was not defined! The
    details of the missing callback are as follows:

    Event Name: onstartupcomplete
    Cancellable: false

    Callback class: d

    If you are the mod author then in order to fix the error you must provide an
    implementation for the specified class, or check that the class name and package
    are correct.

    This is an unrecoverable error, please report it to the mod author and remove
    the offending mod.


    1) b.h(CrashReport.java:72)
    2) b.<init>(CrashReport.java:55)
    3) b.a(CrashReport.java:428)
    4) cua.b(TextureMap.java:224)
    5) cua.a(TextureMap.java:89)
    6) cxh.j(SourceFile:553)
    7) cxh.a(SourceFile:139)
    8) cxk.a(SourceFile:23)
    9) cvt.c(SourceFile:104)
    10) cvt.a(SourceFile:92)
    11) bsu.e(SourceFile:641)
    12) com.mumfrey.liteloader.client.ResourcesClient.refreshResources(ResourcesClient.java:39)
    13) com.mumfrey.liteloader.client.LiteLoaderEventBrokerClient.onStartupComplete(LiteLoaderEventBrokerClient.java:244)
    14) com.mumfrey.liteloader.client.CallbackProxyClient.onStartupComplete(CallbackProxyClient.java:55)
    15) com.mumfrey.liteloader.core.event.EventProxy.$event00000(EventProxy.java:211)
    16) bsu.aj(SourceFile:485)
    17) bsu.a(SourceFile:299)
    18) net.minecraft.client.main.Main.main(SourceFile:120)
    19) sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    20) sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
    21) sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
    22) java.lang.reflect.Method.invoke(Method.java:483)
    23) net.minecraft.launchwrapper.Launch.launch(Launch.java:135)
    24) net.minecraft.launchwrapper.Launch.main(Launch.java:28)
    [11:00:47] [Client thread/ERROR]: Unable to launch
    java.lang.reflect.InvocationTargetException
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) ~[?:1.8.0_25]
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62) ~[?:1.8.0_25]
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) ~[?:1.8.0_25]
    at java.lang.reflect.Method.invoke(Method.java:483) ~[?:1.8.0_25]
    at net.minecraft.launchwrapper.Launch.launch(Launch.java:135) [launchwrapper-1.11.jar:?]
    at net.minecraft.launchwrapper.Launch.main(Launch.java:28) [launchwrapper-1.11.jar:?]
    Caused by: java.lang.NoClassDefFoundError: d
    at b.h(CrashReport.java:72) ~[b.class:?]
    at b.<init>(CrashReport.java:55) ~[b.class:?]
    at b.a(CrashReport.java:428) ~[b.class:?]
    at bsu.a(SourceFile:301) ~[bsu.class:?]
    at net.minecraft.client.main.Main.main(SourceFile:120) ~[Main.class:?]
    ... 6 more

    Posted in: Minecraft Mods
  • 0

    posted a message on LiteLoader
    True I could see that being an issue of people who are impatient not reading everything. Though I've never modded anything in my life & was quite lost in a lot of it.

    Either way thank you very much for your help & time
    Posted in: Minecraft Mods
  • 0

    posted a message on VoxelMap [1.16.1 to 1.7.10] - a minimap and worldmap
    Quote from grimallq»

    Forgot about that ... Read karyonix's release notes. He merged the installer and mod into one file. Just drop it to mods folder.

    Yep that worked thank you. I've got LiteLoader, OptiFine, & Shaders working perfectly. Loads up & playable.

    Dropped the voxelMap.litemod into the .minecraft/mods folder. Now stuck on Reloading Resources.

    Did OP means drop the mod into .minecraft/mods/1.8?
    Posted in: Minecraft Mods
  • 0

    posted a message on LiteLoader
    Okay. I got it all done. Some things that OP should clarify to save a future modder who has NEVER done anything like this some trouble



    • Clarify what a Tweaker Mod is. You're using terminology a non-modder wouldn't know
    • Clarify that the Optifine and ShadersMod .jars do not need to be ran/installed by running them if you plan on installing them. They just need to be dropped into the .minecraft/mods folder. LiteLoader will automatically "install" them by loading them through the mods folder on their own.(It's important you clarify this because I came here from the VoxelMap mod & they don't tell you jack. They just say HERE YA GO/ GO INSTALL THIS THING AND IM NOT GOING TO TELL YOU WHAT THIS THING DOES). It took me longer than necessary to realize how LiteLoader works & what it does. By adding that it makes it obvious to someone coming here from another mod what it does, why you don't need to run/install OptiFine/Shaders if you have previously done so and what not.
    • Clarify to make sure that you are Installing LiteLoader to the current version of the game, NOT to 1.8 Optifine, 1.8 ShadersMod, or any other modified version/.jar of minecraft. LiteLoader will automatically load your Optifine/Shaders through the mods folder. It's assumed we know that & if you've never modded before you won't. By 'change any options' I figured you just meant 'Show incompatible version' or choosing a minecraft directory. I just figured we'd install this off our current modded version. I had no way to know any different. Obviously if I wanted to use Optifine/Shaders I would try to install it off that even if it says choose default options. It's all really confusing if you've never done this before.
    Maybe add it to the FAQ or something, but definitely need to explain/clarify in some way what 'Tweak jars' are & that Optifine/Shaders doesn't need to be hard-installed by running it & just dropped into the mod folder.

    I can see why you'd all think these are stupid makes now that I know how to actually install this but it's very easy to misinterpret what it means in a lot of this if you take the install instructions literal and were brought here from another mod(For me, VoxelMap) and don't have the first clue what 'LiteLoader' actually does
    Posted in: Minecraft Mods
  • 0

    posted a message on LiteLoader

    Looking at the instruction I think it goes like this:
    1. Install Liteloader
    2. Download Optifine/Shaders (these come as tweak jars)
    3. Put them in the mods folder.
    4. Play Minecraft.

    Tweak jars are just jars that are set up to be loaded by the minecraft launcher and make changes before launching the game. Forge, and I think Liteloader as well, support loading those from the mods folder.

    So if I'm using just LiteLoader, OptiFine, Shaders, Texture Pack, Minimap, & Chat mods I don't need to worry about the tweak jars?

    I ask because OP doesn't explain what "tweak jar" technically are. Technically, any type of mod is a tweak. It's why I'm asking. LiteLoader, OptiFine, and Shaders are all setup to be loaded by a minecraft launcher so those are all technically tweaks how you describe it.

    I'm asking all this because I want to be 100% sure. Really really really tired of installing a bunch of stuff only for it not to work out because something was ambiguous.
    Posted in: Minecraft Mods
  • 0

    posted a message on LiteLoader

    Looking at the instruction I think it goes like this:
    1. Install Liteloader
    2. Download Optifine/Shaders (these come as tweak jars)
    3. Put them in the mods folder.
    4. Play Minecraft.

    Tweak jars are just jars that are set up to be loaded by the minecraft launcher and make changes before launching the game. Forge, and I think Liteloader as well, support loading those from the mods folder.

    Thank you.

    OP doesn't mention that. OP just says "You don't need to do anything extra". For someone who hasn't moded before that just says, "Run the installer, because that's what the directions on OptiFine/Shaders says to do" which doesn't work because it gives you a 'LiteLoader' AND a seperate 'OptiFine' profile.

    OP should definitely clarify to move the Optifine & ShadersMod jars into the mods folder if that's what we're supposed to do because it doesn't say that & it's assumed that you just know to do that. Is that what OP means by tweaks? How am I supposed to know that?

    I'll try what you said.

    I've spent a little over 2 hours now trying to figure this out because the instructions are so unclear. Getting quite frustrated
    Posted in: Minecraft Mods
  • 0

    posted a message on LiteLoader
    "Download Optifine and/or ShadersMod"



    Okay. Done that.



    "Copy the additional tweak jars into the"

    What additional tweak jars?

    A lot of stuff is assumed to be known here
    Posted in: Minecraft Mods
  • 0

    posted a message on LiteLoader
    Quote from Mumfrey»

    Looks like he changed it in the new version, you should just be able to use the file as-is, just drop it into /mods/1.8

    I can't test at the moment, I'll try it when I get home.

    Which file? There are over 250 files in the ShadersMod-v2.4.7mc1.8.jar

    http://puu.sh/eRZo1.jpg

    Preview of the shadersmod/client folder: http://puu.sh/eRZsp.png

    There are many folders inside the jar like this.

    Also thank you for helping it seems he has changed basically how everything is setup inside the folders so you'll need to update the tutorial/guide part for if you wish to install Optifine/Shaders
    Posted in: Minecraft Mods
  • 0

    posted a message on VoxelMap [1.16.1 to 1.7.10] - a minimap and worldmap
    Quote from grimallq»

    Read Liteloader thread first post.



    The "Linux/Other" .jar file is just a pure Java app, works everywhere. The Windows .exe and Mac OSX .app are the exact same file but with some OS specific wrappers added on top.



    Except for the newest Windows client, that one's a bit more involved.

    I did. He says, "inside you will find another jar file called ShadersModCore-X.X.XXmcX.XX.jar".

    No, there isn't.

    http://puu.sh/eRYUd.png

    I also checked in EVERY folder in the .zip & there isn't a "ShadersModCore" named .jar.
    Posted in: Minecraft Mods
  • To post a comment, please or register a new account.