• 0

    posted a message on [1.12.2] Fixing OBJ Model Shading

    Hi I'm looking for some help on fixing my items defaulting shading, as by default it isn't a smooth shading.
    Here is what I mean



    Here is what I'm trying to do (this was taking using a shader)



    My models MTL:


    newmtl TEX_w2dkn07
    map_Kd rcraft:items/w2dkn07


    Here is its Blockstate file:


    {
        "forge_marker": 1,
        "variants": {
        "type": {
    		"1": {
    			"model": "rcraft:tribalgrappler/tribalgrappler07l.obj"
    		}
        }
    	},
    	"defaults" : {
    	
    	"transform": {
    	
    	"thirdperson_righthand": {
    	"rotation": [ 0, 180, 0 ],
    	"translation": [ -1.215, 1.02, -0.90 ],
    	"scale": [ 2.30, 2.30, 2.30 ]
    	},
    	"thirdperson_lefthand": {
    		"rotation": [ 0, 180, 180 ],
    		"translation": [ -1.23, -1.27, -0.90 ],
    		"scale": [ 2.30, 2.30, 2.30 ]
    	},
    	"firstperson_righthand": {
    		"rotation": [ 0, 190, 0 ],
    		"translation": [ -0.70, 0.30, -0.50 ],
    		"scale": [ 1.00, 1.00, 1.00 ]
    	},
    	"firstperson_lefthand": {
    		"rotation": [ 0, 0, 0 ],
    		"translation": [ 0.00, 0.00, 0.00 ],
    		"scale": [ 1.00, 1.00, 1.00 ]
    	},
    	"gui": {
    		"rotation": [ 96, 50, 216 ],
    		"translation": [ 0.50, -0.60, 0.00 ],
    		"scale": [ 1.90, 1.90, 1.90 ]
    	},
    	"head": {
    		"rotation": [ 0, 0, 0 ],
    		"translation": [ 0.00, 0.00, 0.00 ],
    		"scale": [ 1.00, 1.00, 1.00 ]
    	},
    	"fixed": {
    		"rotation": [ 0, 0, 0 ],
    		"translation": [ 0.00, 0.00, 0.00 ],
    		"scale": [ 1.00, 1.00, 1.00 ]
    	},
    	"ground": {
    		"rotation": [ 0, 0, 0 ],
    		"translation": [ 0.60, 0.20, 0.60 ],
    		"scale": [ 1.00, 1.00, 1.00 ]
    	}
    	}
    	}
    }


    If you need anything else, please let me know!

    Posted in: Modification Development
  • 0

    posted a message on dotHack Weapons! - Adding in 400+ weapons from .hack/IMOQ and GU/Last Recode to Minecraft!

    Bit of a backlog of updates:
    1.1.1:

    - Added in last Wavemaster weapon

    - Fixed texture not loading.

    1.1.2:

    - Fixes the issue with Harvest Cleric, Shadow Warlock, and Wavemaster staffs losing their names after being used and losing some mana.

    - Fixes the left hand transforms on Harvest Cleric, Shadow Warlock, and Wavemaster staffs.

    1.1.3:

    - Flicker Reaper, Edge Punisher, Blade Brandier, Blade Master, Heavyblade, Long Arm, Lord Partizan, and Heavy Axeman rotations fixed for 3rd and 1st person views.

    Known Issues:
    -Weapons that need finished in left hand for 1st and 3rd person:

    • Macabre Dance

    Still need sized and rotated for 1st and 3rd person:

    • Steam Gunner
    • Dual Gunner
    • Tribal Grappler

    Features Left:

    • Make Dual Guns and Steam Gunner weapons actual guns
    • Make all weapons craftable.

    1.1.4:

    Finished:

    - Twinblade R1

    - Twinblade R2

    - Harvest Cleric

    - Shadow Warlock

    - Wavemaster

    - Flicker Reaper

    - Edge Punisher

    - Blade Brandier

    - Blade Master

    - Heavyblade

    - Long Arm

    - Lord Partizan

    - Heavy Axeman

    - Macabre Dance

    - Dual Gunner

    - Tribal Grappler

    - Steam Gunner

    - Dual Gunner and Steam Gunner now work as bows and shoot arrows for now


    Features Left

    - Make Dual Guns and Steam Gunner weapons fire custom bullets

    - Make all weapons craftable - Make all weapons have custom damage by default


    1.1.5:

    - Fixed the mod only loading Steam Gunner weapons >.>


    1.1.6:

    - Added in dependencies code into the mod for Forge 1.12.2-14.23.4.2705 or higher and Electroblob's Wizardry. Thanks to McHorse/horsewithnoname for the suggestion and help adding it!

    1.2.0:

    - The Crafting Update! Not yet released, lot's work recipes to make!

    Posted in: Minecraft Mods
  • 2

    posted a message on dotHack Weapons! - Adding in 400+ weapons from .hack/IMOQ and GU/Last Recode to Minecraft!

    Because I can and because why not, I bring you this neat little mod I'm using in a private modpack I'm creating. Special thanks to Galaxtone and d4rsorc for all their amazing help in redoing this mod from the ground up!


    Download:


    This mod will be 1.12.2 only, I have no plans on back porting. If anyone wishes to back port this mod, feel free to do a GitHub fork of it and share it with me, I'll gladly upload it and make sure all credits go to you.

    This mod REQUIRES
    Electroblob's Wizardry


    Weapon Models:






    Posted in: Minecraft Mods
  • 0

    posted a message on Mod not working on a server but works Client side.
    Quote from Nuparu00»

    Well, the @SideOnly(Side.CLIENT) annotation in its current position affects your registerItems() method, but not registerModels(). So just move it before a declaration of the registerModels() method, and you should be fine.


    Yeah I got it all sorted out, I just ended up creating a CommonProxy and ClientProxy and running what I needed through them.

    Posted in: Modification Development
  • 0

    posted a message on Mod not working on a server but works Client side.

    So I'm getting

    [net.minecraft.server.MinecraftServer]: Encountered an unexpected exception
    java.lang.NoClassDefFoundError: net/minecraftforge/client/model/ICustomModelLoader

    Not sure why this is doing this as I am using @SideOnly(Side.CLIENT) HERE is my EventHandler, also along with the rest of my code. If I'm just being stupid, please take pity on me lol

    Posted in: Modification Development
  • 1

    posted a message on [1.10.2] CustomSteve 1.4.0Beta [Change the model of Steve to whatever you want!]
    Quote from Videogamer555»

    How do I install this mod? Do I insert it into the JAR file itself? Or do I need to install a mod framework such as Mod Loader or Forge? The opening post in this thread really didn't explain the installation procedure that well. Also, which version(s) of the game does this mod work with?


    Almost any mod made is now using Forge, just assume it's always Forge unless it states otherwise. Game version is literally stated in the Title, it's not hard to miss.

    Posted in: Minecraft Mods
  • 0

    posted a message on [1.10.2] CustomSteve 1.4.0Beta [Change the model of Steve to whatever you want!]
    Quote from DongeinMyonMo»

    Hi

    uhh..

    when I use the *SEUS V11.0 SHADERMOD* and then suddenly why my character model got glowing texture model is this a bug? someone help me i use optfine and forge version even first person i can't Look around.. only Third person can freelook around ... Also Can u fix this bug?


    This looks more like a bug in the shaders not this mod.
    Posted in: Minecraft Mods
  • 0

    posted a message on [1.10.2] CustomSteve 1.4.0Beta [Change the model of Steve to whatever you want!]
    Quote from OCDkirby»

    I have a problem. Whenever I try to use any model that's not Izayoi Sakuya, Some or all of the textures will be black. Nothing I've tried so far fixes this. Any help?


    EDIT: Debug tab is saying that it's unable to find textures that weren't included with the model in the first place. ;-;


    How is your texture located?
    Posted in: Minecraft Mods
  • 0

    posted a message on [1.10.2] CustomSteve 1.4.0Beta [Change the model of Steve to whatever you want!]
    Quote from InuYasha86000»

    My modpack is running on 1.7.10 AND there are mods still being updated and created for 1.7.10.


    Quote from amerem»

    I run a 1.7.10 server with custom modpack am working on another 1.7.10 modpack and server and I am the lead artist for Traincraft which atm is on 1.7.10 no reason to let it go I think.


    You two are part of the problem, that **** is 3 years old and anyone that expects a mod creator to keep backporting to it are asinine. The amount of code difference in 1.10.2 and 1.7.10 is massive.
    Posted in: Minecraft Mods
  • 0

    posted a message on [1.10.2] CustomSteve 1.4.0Beta [Change the model of Steve to whatever you want!]
    Quote from Tcll»

    1.4.0 download for 1.7.10??

    can it be installed on Linux servers??


    No and no 1.7.10 is old as **** man, let it go.
    Posted in: Minecraft Mods
  • 0

    posted a message on Custom NPCs
    Quote from Etheatrix»

    Please do the functions from 1.12 in 1.6.4 if possible, with this version it's better and the server for it is easier to do (google translate)


    Dude 1.6.4 is long dead. You can either upgrade or keep the bugged version. 1.7.10 is luckily enough to receive updates from mod creators anymore.
    Posted in: Minecraft Mods
  • 0

    posted a message on Custom NPCs
    Quote from Dubladockus»

    Fixed!:Hello I installed customnpc on my multiplayer server but when i make an npc other players can't have a dialogue with these npc's they can see and attack the npc but cant talk, however the basic line "hello @p" is possible to receive by the player. Does anyone know why this occurs??


    When a other player uses his npc wand on the npc all dialogue's are empty. so this is why it doesnt show up for them. does anyone know how to fix this?

    I noticed that the other player had another version of customnpc However this version was also 1.11.2 same as mine but one file is may2017 the other file was june2017 this made a difference apparently.


    Of course this made a difference, there was changes in the code in the June compared to May. I'm amazed he was able to even connect
    Posted in: Minecraft Mods
  • 0

    posted a message on Custom NPCs
    Quote from Triliton»

    13.19.0.2178 is for 1.11.2

    Does it work singleplayer then?


    No it does not, it does *not even work loading the world into singleplayer in a vanilla client.

    Posted in: Minecraft Mods
  • 0

    posted a message on Custom NPCs
    Quote from Triliton»

    Hmm,

    This is the recomended Forge version: 13.19.0.2178

    That might be why you crash.

    I'm 1.11.2 not 1.11 and I'm on 13.20.1.2393 as that's the recommend forge for SpongeForge to work, however spongeforge is only server and not clientside so it wouldn't be the issue for single-player.
    Posted in: Minecraft Mods
  • 0

    posted a message on Custom NPCs

    Sadly I've spoken to fast, another world is being effected by this bug. This is server and client side.

    Description: Ticking entity
    
    java.lang.NullPointerException: Ticking entity
    	at noppes.vc.EntityMagicProjectile.func_70071_h_(EntityMagicProjectile.java:25)
    	at net.minecraft.world.World.func_72866_a(World.java:1965)
    	at net.minecraft.world.WorldServer.func_72866_a(WorldServer.java:840)
    	at net.minecraft.world.World.func_72870_g(World.java:1934)
    	at net.minecraft.world.World.func_72939_s(World.java:1748)
    	at net.minecraft.world.WorldServer.func_72939_s(WorldServer.java:621)
    	at net.minecraft.server.MinecraftServer.func_71190_q(MinecraftServer.java:720)
    	at net.minecraft.server.MinecraftServer.func_71217_p(MinecraftServer.java:624)
    	at net.minecraft.server.integrated.IntegratedServer.func_71217_p(IntegratedServer.java:240)
    	at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:482)
    	at java.lang.Thread.run(Unknown Source)
    Posted in: Minecraft Mods
  • To post a comment, please or register a new account.